Bug 140534 - GDB doesn't detect that clone() is out most CFI frame
Summary: GDB doesn't detect that clone() is out most CFI frame
Status: CLOSED DUPLICATE of bug 216506
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gdb (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Alexandre Oliva
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On: 129331
Blocks: 169570
TreeView+ depends on / blocked
 
Reported: 2004-11-23 14:57 UTC by Andrew Cagney
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-30 14:35:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Cagney 2004-11-23 14:57:40 UTC
#4  0x0fe804d0 in clone () from /lib/tls/libc.so.6
#5  0x0fe804d0 in clone () from /lib/tls/libc.so.6
Previous frame identical to this frame (corrupt stack?)

Per disucssion on gdb@:

- glibc should mark up the return-address column of the assembly
function clone() to indicate that it is UNDEFINED.

- GDB should detect this and mark the function as outer-most by
returning a NULL frame ID.

Comment 1 Jan Kratochvil 2006-11-30 14:35:43 UTC
Sure this one was first, just to cleanup a bit BZ.


*** This bug has been marked as a duplicate of 216506 ***


Note You need to log in before you can comment on or make changes to this bug.