Bug 140538 - hald crash during boot
hald crash during boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-23 10:28 EST by Peter Hirdina
Modified: 2013-03-05 22:42 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.4.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 14:53:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output during boot (229.05 KB, text/plain)
2004-11-23 10:30 EST, Peter Hirdina
no flags Details
my output (not connected with vmware) (132.51 KB, text/plain)
2004-12-18 17:51 EST, Boris Glawe
no flags Details
output of hald (115.72 KB, text/plain)
2005-01-02 03:27 EST, Dimitri Papadopoulos
no flags Details
running hald in gdb (1.01 KB, text/plain)
2005-01-02 03:37 EST, Dimitri Papadopoulos
no flags Details

  None (edit)
Description Peter Hirdina 2004-11-23 10:28:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
hald crashes on my system during boot. Usually when I restart it
afterwards it keeps running (not always but most of the time). To me
it seems to be related with the huge amount of devices files of
vmware. (see attachment for output of hald).

Version-Release number of selected component (if applicable):
hal-0.4.0-10

How reproducible:
Always

Steps to Reproduce:
1.
Install vmware (as mentioned in the release instructions)
2.
Reboot
3.
hald should have been crashed

Additional info:
Comment 1 Peter Hirdina 2004-11-23 10:30:14 EST
Created attachment 107304 [details]
output during boot
Comment 2 Boris Glawe 2004-12-18 17:51:58 EST
Created attachment 108852 [details]
my output (not connected with vmware)

I've got the same problem with hald.

My hardware: Asus a7n8x-e deluxe Mainboard with nforce2 chipset and AMD XP 2800
processor and 512MB PC3200 RAM

I've also got a vmware installation, though it's not used and it's services are
never started. Running /etc/init.d/vmware stop does not help.

The output, I've attached,  doesn't show anything connected with vmware,
though. hald is kick out with a segmentation fault. I ran it with the command
"hald --verbose=yes --daemon=no"
Comment 3 Kevin Trotman 2004-12-29 11:52:44 EST
I also have this problem and it is always reproducable but never puts
messages in the messages log. I have a 32-bit install of FC3 on an
AMD-64. Several things never worked for me with 64-bit install, but I
never had hal problems. when 32-bit was installed suddenly no CD's
could be mounted or USB devices. Tracked it back to hal dieing
repeatedly, even after boot, whenever it was started up. I also have a
vmware install, but have never been able to get the OS installed on
the vmware partition due to this bug (can't mount install CD). But I
also have some problems mounting the disks manually after hal dies, so
it may be a difference in the underlying amd architecture. I have
occationally seen the cdrom mont messages below, but never any
messages as to why hal dies. Hal died probably before finishing the
mount below as I tried restarting it directly afterward.


Dec 27 14:59:37 barracuda haldaemon: haldaemon startup succeeded
Dec 27 14:59:37 barracuda fstab-sync[17649]: removed all generated
mount points
Dec 27 14:59:38 barracuda fstab-sync[17746]: added mount point
/media/cdrecorder for /dev/hda
Dec 27 15:00:02 barracuda crond(pam_unix)[17826]: session closed for
user root
Dec 27 15:00:54 barracuda kernel: cdrom: open failed.
Dec 27 15:00:54 barracuda kernel: cdrom: open failed.
Comment 4 Dimitri Papadopoulos 2005-01-02 03:21:51 EST
I can reproduce hald crashing during boot, although I'm not really
sure this is related. Please do not hesitate to ask me to enter a new
bug if it isn't.

The init script fails to see hald doesn't start:
# cd /etc/init.d
# ./haldaemon start
Starting HAL daemon:                                       [  OK  ]
# ./haldaemon status
hald is stopped
# 

Then I try starting hald directly:
hald --verbose=yes --daemon=no
and it fails with a segmentation fault. Output attached.
Comment 5 Dimitri Papadopoulos 2005-01-02 03:27:41 EST
Created attachment 109230 [details]
output of hald

I currently run the latest package:
	hal-0.4.2-1.FC3
Comment 6 Dimitri Papadopoulos 2005-01-02 03:37:41 EST
Created attachment 109231 [details]
running hald in gdb
Comment 7 Brian G. Anderson 2005-01-07 03:54:17 EST
I just did a fresh install of FC3 followed by up2date today and I get
this behavior also: hald service claims to start OK at boot, but a
status check shows that it is stopped.  There are messages in the log:

Jan  7 00:49:56 kelly haldaemon: haldaemon startup succeeded
Jan  7 00:49:56 kelly fstab-sync[5396]: removed all generated mount points
Jan  7 00:49:57 kelly fstab-sync[5505]: added mount point
/media/cdrecorder for
/dev/hdd
Jan  7 00:49:57 kelly fstab-sync[5514]: added mount point
/media/cdrecorder1 for /dev/hdc
Jan  7 00:49:57 kelly fstab-sync[5618]: added mount point
/media/floppy for /dev/fd0

but nothing about a failure.  I'm running on a AMD-64 processor, but
with with a i686 install.  However, I also have a AMD Athelon which
exhibits the exact same behavior. I don't get this problem on my Dell
laptop running a Intel P4Mobile.
Comment 8 Boris Glawe 2005-01-13 14:47:24 EST
the current update (hal-0.4.5-1.FC3) solved the problem for me !
Comment 9 David Zeuthen 2005-01-13 14:53:26 EST
Ah, right, this looks like bug 142183 which was just closed. Closing
this bug; thanks.
Comment 10 Dimitri Papadopoulos 2005-01-25 04:56:38 EST
The current update (hal-0.4.6-1.FC3) also solved the problem for me.

Note You need to log in before you can comment on or make changes to this bug.