Bug 140555 - APM resume hoses keyboard
APM resume hoses keyboard
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-11-23 11:29 EST by Ian Soboroff
Modified: 2015-01-04 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-10-02 19:59:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ian Soboroff 2004-11-23 11:29:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)

Description of problem:
I booted with 'acpi=off' and suspended my laptop by closing the lid. 
Upon resuming, the keyboard does not work correctly.  When the first
key is pressed, an unending stream of garbage characters is emitted. 
I can't switch consoles, kill X, or reboot the machine via the keyboard.

Prior to upgrading to FC3, I was running FC2 with a vanilla 2.6.7
kernel, as well as a couple 2.6.9-acs.  The above behavior would
happen under all 2.6.9 versions I tried (vanilla as well as ac3), but
2.6.7 was OK.  (I never tried 2.6.8 for very long, I found that X
would die under load, but that's a bug for another day.)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot with ACPI disabled
2. suspend
3. resume
4. press any key
5. watch madness ensue

Additional info:
Comment 1 Dave Jones 2005-07-15 15:20:41 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 2 Dave Jones 2005-10-02 19:59:35 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.