Bug 14056 - RPM doesn't upgrade some files in 'setup' at all.
RPM doesn't upgrade some files in 'setup' at all.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-15 19:13 EDT by Pekka Savola
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-15 19:13:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2000-07-15 19:13:20 EDT
Writing from memory as the testbox is down at the moment.

I think this happened "inside" the beta3 system, ie. I was force-upgrading
setup from beta3 to setup from beta3.

1) Modify some files in /etc/ a little, like profile or bashrc

2) Check that they're changed by rpm -V

3) Upgrade the respective RPM.

4) Notice that that file was _not_ upgraded (even though it was
significantly changed).  Also .rpm{save, orig} was not created either.
Effectively, changes in the file were lost.

The only way to get around that was to delete the file, and then upgrade.
Comment 1 Jeff Johnson 2000-07-19 11:16:11 EDT
This is a feature, not a bug in rpm. For config files, if the attributes (MD5
sum, mode, perms, etc)
of a file from a new package are identical to the old package, then a modified
local copy
of the file on disk is not changed, nor are *.rpmnew and *.rpmorig files
created.

Note You need to log in before you can comment on or make changes to this bug.