Bug 140565 - xmms pause doesn't unpause
xmms pause doesn't unpause
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xmms (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-23 12:29 EST by John Haxby
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2.10-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-23 16:43:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for pause problem (11.89 KB, patch)
2004-11-23 12:33 EST, John Haxby
no flags Details | Diff

  None (edit)
Description John Haxby 2004-11-23 12:29:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
If you click on the pause button with xmms, then clicking on pause
again doesn't unpause the audio.   Clicking on play starts the paused
track from the beginning.  Equally "xmms --play-pause" doesn't toggle
between playing and pausing as it should.

Version-Release number of selected component (if applicable):
xmms-1.2.10-9

How reproducible:
Always

Steps to Reproduce:
1. Start up xmms and select the alsa output plugin
2. Start playing something
3. Run "xmms --play-pause" to pause the audio
4. Run "xmms --play-pause" again
    

Actual Results:  Sound does not continue.

Expected Results:  Sound continues :-)

Additional info:

I'm not sure if it's necessary to select the ALSA output plug-in, I
didn't actually try this with either esd or arts but since both of
those give me considerable grief for other audio applications I do
rather tend to avoid them in favour of clever stuff in ~/.asoundrc.

You don't need to run "xmms --play-pause" you can just click on the
pause button.
Comment 1 John Haxby 2004-11-23 12:33:24 EST
Created attachment 107314 [details]
Fix for pause problem

This bug is fixed in the xmms CVS sources.  This patch is just the alsa output
plug-in patch.	I just added it as patch12 to the xmms source and applied it
after all the other patches.   It works a treat.  The "play/pause" button on my
laptop can now be configured to work!
Comment 2 Colin Walters 2004-11-23 16:43:20 EST
Built into rawhide as 1.2.10-10.  I'll do the same in RHEL4 once it's had some
rawhide testing.  Thanks for getting the patch. 

This bug might be related to bug 116709 by the way.
Comment 3 Barry K. Nathan 2004-12-06 19:29:54 EST
I've verified that 1.2.10-10 fixes the problem for me, too.

Note You need to log in before you can comment on or make changes to this bug.