Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: Short version: greeter-session in /etc/lightdm/lightdm.conf was lightdm-greeter instead of lightdm-gtk-greeter. After upgrading from Fedora 24 to 25 (Cinnamon Spin) boot would hang just before lightdm would start. Changed to tty2, did a startx, and got a working Cinnamon session. Checked the lightdm log and it said "Failed to find session configuration lightdm-greeter." Looked in /usr/share/xgreeters and the only session file was lightdm-gtk-greeter.desktop. Changed /etc/lightdm/lightdm.conf to greeter-session=lightdm-gtk-greeter and lightdm starts successfully. Version-Release number of selected component (if applicable): How reproducible: Steps to Reproduce: 1. Upgrade F24 Cinnamon Spin to F25 2. Reboot 3. Actual results: lightdm fails to start (greeter session name in /usr/share/xgreeters does not match greeter-session name in /etc/lightdm/lightdm.conf). Expected results: lightdm.conf and xgreeters session have matching names and lightdm starts successfully. Additional info:
I'd have expected lightdm-gtk's /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf snippet to to precedence. lightdm's default /etc/lightdm/lightdm.conf should also have the greeter-session= key commented out, but since it's marked as a %config file, you may have modified it at some point in the past. Given that ^^, we may need to include a scriptlet to drop/remove any local modifications to lightdm.conf somehow (maybe just comment-out any line starting with greeter-session=
*** Bug 1400398 has been marked as a duplicate of this bug. ***
I took a look at the F24 Cinnamon Live USB I installed from and the following line appears uncommented in /etc/lightdm/lightdm.conf greeter-session=lightdm-greeter However, it also has /usr/share/xgreeters/lightdm-greeter.desktop which is symlinked to /etc/alternatives/lightdm-greeter which is symlinked to /usr/share/xgreeters/lightdm-gtk-greeter.desktop Neither of these symlinks are on my upgraded F25 install.
This package has changed ownership in the Fedora Package Database. Reassigning to the new owner of this component.
This message is a reminder that Fedora 25 is nearing its end of life. Approximately 4 (four) weeks from now Fedora will stop maintaining and issuing updates for Fedora 25. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as EOL if it remains open with a Fedora 'version' of '25'. Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version. Thank you for reporting this issue and we are sorry that we were not able to fix it before Fedora 25 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora, you are encouraged change the 'version' to a later Fedora version prior this bug is closed as described in the policy above. Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete.
Fedora 25 changed to end-of-life (EOL) status on 2017-12-12. Fedora 25 is no longer maintained, which means that it will not receive any further security or bug fix updates. As a result we are closing this bug. If you can reproduce this bug against a currently maintained version of Fedora please feel free to reopen this bug against that version. If you are unable to reopen this bug, please file a new report against the current release. If you experience problems, please add a comment to this bug. Thank you for reporting this bug and we are sorry it could not be fixed.