Bug 1405709 - Change default input method for Chinese (Taiwan) to ibus-libzhuyin
Change default input method for Chinese (Taiwan) to ibus-libzhuyin
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-desktop (Show other bugs)
25
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
https://bugzilla.gnome.org/show_bug.c...
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-17 12:23 EST by Cheng-Chia Tseng
Modified: 2017-09-01 21:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-01 21:24:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cheng-Chia Tseng 2016-12-17 12:23:16 EST
Description of problem:
ibus-libzhuyin has been proposed to be the default input method for Chinees (Taiwan). I have installed a fresh fedora 24 (f25 also) in Chinese (Taiwan) language and found some problems in setup.

Problems:
1. gnome-initial-setup only lists "chewing" (ibus-chewing).
2. the default input method for Chinese (Taiwan) language since fedora 24 is "New Zhuyin" (ibus-libzhuyin). ibus-libzhuyin is installed by default, but not listed in the setup dialogue.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. First login into a fresh user using Chinese (Taiwan) (zh_TW) locale
2. Set input method for Chinese (Taiwan) in the gnome-initial-setup dialogue

Actual results:
1. "chewing" is the only available input method listed

Expected results:
1. gnome-initial-setup list all the available input methods of user's locale which installed on the system.
2. For example, when adding new input sources in System Settings > Language & Regions, gnome can list the available input methods for my locale (which is Chinese (Taiwan)) directly, and so should gnome-initial-steup does.

Additional info:
I also filed a upstream bug report at https://bugzilla.gnome.org/show_bug.cgi?id=772674
Comment 1 Peng Wu 2016-12-19 04:21:21 EST
I think first we need to change the Taiwan default input method in Fedora,
then consider to list all language related input methods.

I copied this bug in : https://bugzilla.redhat.com/show_bug.cgi?id=1405946
Comment 2 Cheng-Chia Tseng 2017-09-01 21:24:27 EDT
Fixed in Fedora 26.

Note You need to log in before you can comment on or make changes to this bug.