Bug 140572 - error during read on /dev/hda
error during read on /dev/hda
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Cox
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-23 13:01 EST by Jim Starkey
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 03:16:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Starkey 2004-11-23 13:01:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
SV1; .NET CLR 1.1.4322)

Description of problem:
Installing from ISO images; installation disk passes media check.
Box is Compaq Pressario 6000 w/ AMD 1800+ processor (utter vanilla 
cheap Compaq box).  System currently has RedHat 8.0 installed that 
runs without any problems.

After selecting keyboard, installation hangs for about a minute, then 
reports "Input/output error during read on /dev/hda".

After reboot, the boot rom self test fails (can't see hard disk).  
This persists until cleared by cycling power.

The problem is reproducable.

Version-Release number of selected component (if applicable):
Fedora Core 3 (IA32)

How reproducible:
Always

Steps to Reproduce:
1. Boot first installation disk
2. Pick mouse
3. Pick keyboard    

Actual Results:  Dialog box "Input/out error during read 
on /dev/hda".  Subsequence reboot fails in self test without a power 
cycle.

Expected Results:  I presume Fedora would have installed itself...

Additional info:
Comment 1 Dave Jones 2004-11-27 00:03:50 EST
do you still have RHL8 installed ?  Can you try the following things ?

- output of fdisk -l /dev/hda  (as root)

- try dd if=/dev/hda of=/dev/null and see if it completes without errors.

if you dont have rhl8 installed still, you can get to a tty by booting the
installer to the graphical stage, then hitting ctrl-alt-f2
Comment 2 Jim Starkey 2005-01-13 18:27:10 EST
Sorry for the delay -- I assumed I'd hear by email if you needed 
anything.

RH8 is still installed.  Here is the listing you requested:

[root@ernie jas]# /sbin/fdisk -l /dev/hda

Disk /dev/hda: 240 heads, 63 sectors, 5174 cylinders
Units = cylinders of 15120 * 512 bytes


   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1        14    105808+  83  Linux
/dev/hda2            15      3622  27276480   83  Linux
/dev/hda3          3623      4941   9971640   83  Linux
/dev/hda4          4942      5174   1761480    f  Win95 Ext'd (LBA)
/dev/hda5          4942      5010    521608+  83  Linux
/dev/hda6          5011      5148   1043248+  83  Linux
/dev/hda7          5149      5174    196528+  82  Linux swap

[root@ernie jas]# dd if=/dev/hda of=/dev/null
78242976+0 records in
78242976+0 records out
[root@ernie jas]#

Comment 3 Alan Cox 2005-04-12 09:54:06 EDT
No immediate ideas. Would need to know chipset and drive type to go further.

Can you attach lspci -vxx and hdparm -I /dev/hda (off RH8 is fine)

Alan
Comment 4 Dave Jones 2005-07-15 13:40:18 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.