Bug 140582 - Not able to add machines to samba domain under Fedora Core 3
Not able to add machines to samba domain under Fedora Core 3
Status: CLOSED DUPLICATE of bug 138782
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-23 13:41 EST by Paul Espinosa
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Espinosa 2004-11-23 13:41:39 EST
Description of problem:

When samba is configures to be a PDC and you try to add a new machine
to the domain samba adds a machine account to the samba user database
and the unix passwd file.  In order to differentiate this machine
account from a regular user account samba uses a '$' as a suffix to
the name.  Previously to FC3 adding a user account in the form of
'machine1$' worked fine with a command of something similiar to:
useradd machine1\$  (with whatever preferences for group and home
directory - I used -d /dev/null -g machines).

In FC3 this no longer works.  This is the attempt and error message:

	root@server(~): useradd machine1\$
	useradd: invalid user name 'machine1$'

So as it stands FC3 is not usable to run samba as a domain controller.

Version-Release number of selected component (if applicable):

samba-3.0.8-0.pre1.3 on FC3 i386

How reproducible:

Always

Steps to Reproduce:
1. run useradd machine1\$
2.
3.
  
Actual results:

useradd: invalid user name 'machine1$'

Expected results:

User machine1$ added to system

Additional info:
Comment 1 Jay Fenlason 2004-11-23 14:09:29 EST
This isn't a Samba problem.  This is a shadow-utils problem that 
breaks Samba.  I'm redirecting this to the correct component. 
Comment 2 Sitsofe Wheeler 2004-11-23 17:17:15 EST
Looks a lot like bug 138782
Comment 3 Eido Inoue 2004-11-24 00:16:42 EST

*** This bug has been marked as a duplicate of 138782 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:07:15 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.