Bug 1405841 - CheckListCtrlMixin and TreeMixin checkboxes visually broken
Summary: CheckListCtrlMixin and TreeMixin checkboxes visually broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wxGTK3
Version: 24
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Scott Talbert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-18 21:27 UTC by markusN
Modified: 2017-01-07 22:48 UTC (History)
4 users (show)

Fixed In Version: wxGTK3-3.0.2-31.fc25 wxGTK3-3.0.2-31.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-07 21:49:13 UTC
Type: Bug


Attachments (Terms of Use)

Description markusN 2016-12-18 21:27:21 UTC
In the currently shipped wxPython package the CheckListCtrlMixin and TreeMixin checkboxes are broken.

Easily seen with the demos from wxPython-docs-3.0.2.0-10.fc24.noarch

python /usr/share/doc/wxPython-docs/demo/CheckListCtrlMixin.py
--> visually broken, i.e. black background, black check.

python /usr/share/doc/wxPython-docs/demo/TreeMixin.py
--> visually broken, i.e. no checkbox visible (it is in the CustomTreeCtrl tab)


I would note that this checkbox works fine:
python /usr/share/doc/wxPython-docs/demo/CheckListBox.py

This is at least affecting the wxGUI of GRASS GIS 7.

Comment 1 Scott Talbert 2016-12-18 22:40:19 UTC
The problem is wxRenderer's DrawCheckBox is broken on GTK+ 3.20.  It has been fixed upstream, however.

Comment 2 Fedora Update System 2016-12-28 21:00:10 UTC
wxGTK3-3.0.2-31.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-50f421707b

Comment 3 Fedora Update System 2016-12-28 21:01:07 UTC
wxGTK3-3.0.2-31.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f834c6eb91

Comment 4 Fedora Update System 2016-12-29 09:21:18 UTC
wxGTK3-3.0.2-31.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-50f421707b

Comment 5 markusN 2016-12-29 13:28:13 UTC
(In reply to Fedora Update System from comment #3)
> wxGTK3-3.0.2-31.fc24 has been submitted as an update to Fedora 24.
> https://bodhi.fedoraproject.org/updates/FEDORA-2016-f834c6eb91

I wanted to test this using

dnf --enablerepo=updates-testing update wxGTK3

but it appears to be locked on bodhi.

Comment 6 Scott Talbert 2016-12-29 21:01:51 UTC
(In reply to markusN from comment #5)
> (In reply to Fedora Update System from comment #3)
> > wxGTK3-3.0.2-31.fc24 has been submitted as an update to Fedora 24.
> > https://bodhi.fedoraproject.org/updates/FEDORA-2016-f834c6eb91
> 
> I wanted to test this using
> 
> dnf --enablerepo=updates-testing update wxGTK3
> 
> but it appears to be locked on bodhi.

Correct, it hasn't been pushed to testing for F24 yet.

Comment 7 Fedora Update System 2016-12-30 19:49:28 UTC
wxGTK3-3.0.2-31.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f834c6eb91

Comment 8 Fedora Update System 2017-01-07 21:49:13 UTC
wxGTK3-3.0.2-31.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2017-01-07 22:48:59 UTC
wxGTK3-3.0.2-31.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.