Bug 1405922 - auto-attach control does not work from client in CLI
Summary: auto-attach control does not work from client in CLI
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.9
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: John Sefler
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On: 1019227 1460939
Blocks: sam20-tracker rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2016-12-19 07:55 UTC by qianzhan
Modified: 2017-06-13 17:45 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1019227
Environment:
Last Closed: 2017-06-13 17:45:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6012 None None None 2016-12-19 07:55:07 UTC

Comment 3 Kevin Howell 2017-01-03 15:59:35 UTC
We hypothesize that this is expected behavior based on the steps described; if the preference box is closed, we think that the value is being updated on the SAM instance, thus resulting in what *appears* to be inconsistent behavior, but is really the result of stale state as mentioned by Carter in bug 1019227 (https://bugzilla.redhat.com/show_bug.cgi?id=1019227#c4). A developer should try to reproduce, and validate this hypothesis.

Comment 5 Jiri Hnidek 2017-06-07 12:42:24 UTC
It look as duplicate of this bug: https://bugzilla.redhat.com/show_bug.cgi?id=1444259 and this bug was closed as wontfix. What about this bug?

Comment 6 Kevin Howell 2017-06-13 17:45:01 UTC
Closing with same rationale as https://bugzilla.redhat.com/show_bug.cgi?id=1444259#c20 :

The user can set auto-attach preferences w/ the SAM UI, and we're not planning on fixing auto-attach from CLI in SAM.


Note You need to log in before you can comment on or make changes to this bug.