Bug 140594 - installer crashes (unhandled exception) in partitioning
installer crashes (unhandled exception) in partitioning
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-23 14:28 EST by david d zuhn
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-24 23:56:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
python error call stack (802 bytes, text/plain)
2004-11-23 14:29 EST, david d zuhn
no flags Details
The kickstart file used during the installation (2.09 KB, text/plain)
2004-11-23 14:30 EST, david d zuhn
no flags Details

  None (edit)
Description david d zuhn 2004-11-23 14:28:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I'm doing a kickstart based installation on a Dell2650, using RHEL 3 U3. 

The node contains a QLogic 2200 HBA, plus a single SCSI disk.

A dialog comes up with an unhandled python exception.  The traceback
will be attached to this bug, as will the kickstart file.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install with attached kickstart file.  crash occurs automatically
    

Actual Results:  System crashes.

Expected Results:  System should install properly.

Additional info:
Comment 1 david d zuhn 2004-11-23 14:29:10 EST
Created attachment 107324 [details]
python error call stack
Comment 2 david d zuhn 2004-11-23 14:30:12 EST
Created attachment 107325 [details]
The kickstart file used during the installation

Some sensitive information has been changed (nisdomain, comment text, and the
root password).
Comment 3 david d zuhn 2004-11-23 14:46:35 EST
This was partly  a case of having a misunderstanding of the hardware
situation on this machine.  The local drive is seen as sda on this
machine, while the kickstart file was set up for sde.  

I've lowered the severity, as there is an easy workaround (get the
drives listed correctly in the kickstart file).  The bug is still
open, since this case should have been handled more gracefully than a
python traceback.

Comment 4 Jeremy Katz 2004-11-24 23:56:38 EST
Kickstart's handling of errors is generally giving a traceback.  Newer
code makes the errors be a little bit better, but there's still not a
good unified way of presenting them more reliably to a user.  There's
another RFE open about overall improvements of kickstart's error handling.

Note You need to log in before you can comment on or make changes to this bug.