Bug 1405967 - [RFE] Ability to filter virt-who hosts based on hostnames using wildcard
Summary: [RFE] Ability to filter virt-who hosts based on hostnames using wildcard
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who
Version: 7.0
Hardware: All
OS: Linux
unspecified
low
Target Milestone: pre-dev-freeze
: 7.3
Assignee: Patrick Creech
QA Contact: Eko
Yehuda Zimmerman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-19 11:13 UTC by Abhishek Sahni
Modified: 2018-02-05 15:42 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Regular expressions and wildcards can be used in some *virt-who* configuration parameters With this update, regular expressions and wildcards can be used in the "filter_hosts" and "exclude_hosts" configuration parameters. This enables users of *virt-who* to maintain a list of hosts to report on with much more ease. By using regular expressions and wildcards to specify which hosts to report on or exclude, the hosts list can be much more concise.
Clone Of:
Environment:
Last Closed: 2017-08-01 19:24:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github /virt-who virt-who pull 44 None None None 2017-01-18 20:34:02 UTC
Red Hat Product Errata RHBA-2017:2084 normal SHIPPED_LIVE virt-who bug fix and enhancement update 2017-08-01 18:14:28 UTC

Description Abhishek Sahni 2016-12-19 11:13:12 UTC
Description of problem:

Ability to filter virt-who hosts based on hostnames using wildcard

Version-Release number of selected component (if applicable):

# rpm -q virt-who
virt-who-0.17-9.el7sat.noarch


How reproducible:

100%

Steps to Reproduce:
1. [root@localhost ~]# vi /etc/virt-who.d/config

[config]
type=<hypervisor_type>            (any)
server=<vcenter/esx host>         (any)
username=<vcenter/esx_username>   (any)
owner=<owner>                     (any)
env=Library                       (any)

filter_hosts=myhost1.abc.com,myhost2.abc.com,myhost3.abc.com (current scenario)

filter_hosts=myhost*.abc.com     (Requested Scenario)

OR

filter_hosts=myhost*             (Requested Scenario)


Actual results:


Expected results:

All host should be reported to satellite started with given string "myhost" or having myhost*.abc.com


Additional info:

There is an option i.e. exclude_hosts should also allow to use wildcard similar to previous one.

Comment 2 Bryan Kearney 2016-12-20 20:30:44 UTC
No, this is not. I am moving this to virt-who to have csnyder triage.

Comment 9 errata-xmlrpc 2017-08-01 19:24:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2084


Note You need to log in before you can comment on or make changes to this bug.