Bug 1406164 - var-lib-nfs-rpc_pipefs.mount fails
var-lib-nfs-rpc_pipefs.mount fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils (Show other bugs)
7.3
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Steve Dickson
Yongcheng Yang
: ZStream
: 1293933 (view as bug list)
Depends On:
Blocks: 1385242 1411653
  Show dependency treegraph
 
Reported: 2016-12-19 16:15 EST by Jonathan Lebon
Modified: 2017-08-01 15:48 EDT (History)
11 users (show)

See Also:
Fixed In Version: nfs-utils-1.3.0-0.35.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1411653 (view as bug list)
Environment:
Last Closed: 2017-08-01 15:48:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Lebon 2016-12-19 16:15:10 EST
Description of problem:

systemd fails to mount /var/lib/nfs/rpc_pipefs because it runs before systemd-tmpfiles-setup.service, which creates the file structure there.

Version-Release number of selected component (if applicable):

# rpm-ostree status
State: idle
Deployments:
● rhel-atomic-host:rhel-atomic-host/7/x86_64/standard
       Version: 7.3.1 (2016-11-30 02:14:24)
        Commit: 42cfe1ca3305defb16dfd59cd0be5c539f19ea720dba861ed11e13941423ae86
        OSName: rhel-atomic-host

Steps to Reproduce:
1. Boot up 7.3.1-1.

Actual results:

/var/lib/nfs/rpc_pipefs isn't mounted.

Expected results:

/var/lib/nfs/rpc_pipefs is mounted.

Additional info:

As expected, doing `systemctl restart var-lib-nfs-rpc_pipefs.mount` later works.
Comment 1 Jonathan Lebon 2016-12-19 16:19:10 EST
This is also an issue in 7.3.0:

# rpm-ostree status                                                                                    
State: idle
Deployments:
● rhel-atomic-host:rhel-atomic-host/7/x86_64/standard
       Version: 7.3 (2016-10-26 14:24:09)
        Commit: 90c9735becfff1c55c8586ae0f2c904bc0928f042cd4d016e9e0e2edd16e5e97
        OSName: rhel-atomic-host

# systemctl status var-lib-nfs-rpc_pipefs.mount
● var-lib-nfs-rpc_pipefs.mount - RPC Pipe File System
   Loaded: loaded (/usr/lib/systemd/system/var-lib-nfs-rpc_pipefs.mount; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since Mon 2016-12-19 21:16:26 UTC; 53s ago
    Where: /var/lib/nfs/rpc_pipefs
     What: sunrpc
  Process: 581 ExecMount=/bin/mount sunrpc /var/lib/nfs/rpc_pipefs -t rpc_pipefs (code=exited, status=32)

Dec 19 21:16:26 localhost.localdomain mount[581]: mount: mount point /var/lib/nfs/rpc_pipefs does not exist
Comment 2 Brent Baude 2016-12-19 16:27:23 EST
This is tripping selinux issues in cloud-init and therefore blocking enablement progress on Azure at this point.
Comment 3 Jonathan Lebon 2016-12-19 16:33:01 EST
(In reply to Brent Baude from comment #2)
> This is tripping selinux issues in cloud-init and therefore blocking
> enablement progress on Azure at this point.

Well, it's *one* issue I noticed from your Azure logs. I'm still not sure if it's *the* issue blocking you currently. The machine should boot up fine without that mount succeeding (and it does over here).
Comment 4 Brent Baude 2016-12-19 17:57:59 EST
It is tripping an OSError in cloud-init; hence the failure.  Would be good to see this resolved so I can eliminate it as root cause and so forth
Comment 6 Jonathan Lebon 2016-12-20 11:06:15 EST
OK right, we need the same fix as upstream in https://bugzilla.redhat.com/show_bug.cgi?id=1219871 here:

http://pkgs.fedoraproject.org/cgit/rpms/nfs-utils.git/commit/?id=feea4f146dc282fcea12feb8085e7bd9ff7abd6a

Transferring to nfs-utils component.
Comment 8 Steve Dickson 2017-01-05 16:29:25 EST
commit 8b3abe3a0ae941f3f52f99bc44388b7beb3d9bb8
Author: Colin Walters <walters@verbum.org>
Date:   Fri Jun 26 09:31:16 2015 -0400

    systemd: Set var-lib-nfs-rpc_pipefs.mount After= tmpfiles
Comment 18 Colin Walters 2017-02-28 09:42:11 EST
*** Bug 1427537 has been marked as a duplicate of this bug. ***
Comment 19 Colin Walters 2017-02-28 09:42:28 EST
*** Bug 1293933 has been marked as a duplicate of this bug. ***
Comment 21 Yongcheng Yang 2017-06-16 02:29:49 EDT
Thanks Jonathan for helping to verify this issue as comment #13.

No regression is found till now. Moving to VERIFIED.
Comment 22 errata-xmlrpc 2017-08-01 15:48:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2233

Note You need to log in before you can comment on or make changes to this bug.