Bug 140635 - SELinux Targeted prevents Syslog from starting properly
Summary: SELinux Targeted prevents Syslog from starting properly
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-23 22:01 UTC by Ed Holden
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 14:10:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output when SELinux is enabled with a targeted policy (13.81 KB, text/plain)
2004-11-24 15:02 UTC, Ed Holden
no flags Details

Description Ed Holden 2004-11-23 22:01:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When the SELinux targeted policy is enabled, the syslog daemon does
not properly start.  I noticed this because log messages that should
have appeared in /var/log/messages or /var/log/secure were appearing
on the console, though syslog was not configured to send them there. 
I tried reinstalling the sysklogd RPM with no joy.  In the end,
disabling SELinux fixed the problem.  Whether this is an issue with
syslogd accessing the log files or simply starting is unclear.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.17.30-2.19

How reproducible:
Always

Steps to Reproduce:
1. Enable Targeted policy in SELinux.
2. Reboot.
    

Actual Results:  syslogd does not start, and the init script hangs

Expected Results:  syslogd should start and log events with clear
enthusiasm.

Additional info:

Comment 1 Daniel Walsh 2004-11-24 11:16:32 UTC
Could you attach the dmesg output when syslog fails?

Dan

Comment 2 Ed Holden 2004-11-24 15:02:00 UTC
Created attachment 107391 [details]
dmesg output when SELinux is enabled with a targeted policy

Here it is: I re-enabled SELinux, which is set to use the targeted poliy, in
/etc/selinux/config.  This is the resulting dmesh file.

Comment 3 David Juran 2004-11-27 12:39:07 UTC
touch /.autorelabel and then a reboot solved things for me.
Is this really a duplicate of bug 140100?

Comment 4 Daniel Walsh 2004-11-29 14:10:44 UTC
Both are labeling problems.


Note You need to log in before you can comment on or make changes to this bug.