Bug 1406360 - xl2tpd.x86_64 0:1.3.8-1.el7 will not install - Requires: kmod(l2tp_ppp.ko)
xl2tpd.x86_64 0:1.3.8-1.el7 will not install - Requires: kmod(l2tp_ppp.ko)
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: xl2tpd (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Paul Wouters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-20 06:45 EST by Trevor Hemsley
Modified: 2017-02-08 11:44 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-08 11:44:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trevor Hemsley 2016-12-20 06:45:22 EST
Description of problem:
Version of xl2tpd from epel-testing for EPEL7 will not install. 

Version-Release number of selected component (if applicable):
0:1.3.8-1.el7

How reproducible:
Always

Steps to Reproduce:
1. yum --enablerepo=epel-testing update
2.
3.

Actual results:
---> Package xl2tpd.x86_64 0:1.3.6-8.el7 will be updated
---> Package xl2tpd.x86_64 0:1.3.8-1.el7 will be an update
--> Processing Dependency: kmod(l2tp_ppp.ko) for package: xl2tpd-1.3.8-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: xl2tpd-1.3.8-1.el7.x86_64 (epel-testing)
           Requires: kmod(l2tp_ppp.ko)

Expected results:
Should install cleanly

Additional info:
Comment 1 Tuomo Soini 2016-12-20 06:46:47 EST
Paul: you fixed this before by removing that kmod requirement.
Comment 2 Paul Stauffer 2016-12-20 08:09:16 EST
Note that the broken package is in the release "epel" repo, not just in "epel-testing", so production systems are seeing this as well.

FWIW, here's the changelog line Tuomo is referring to:

* Fri Oct 31 2014 Paul Wouters <pwouters@redhat.com> - 1.3.6-7
- Remove kmod require, not recognised and l2tp_ppp.ko is in core kernel package now
Comment 3 Tuomo Soini 2016-12-20 08:50:53 EST
Yes. This needs priority fixing without 2 weeks waiting time.
Comment 4 Daniel Needles 2016-12-21 19:12:48 EST
I am seeing this problem when trying to set up MATE on CentOS 7.

To reproduce:
1.	Install CentOS 7.3.1611 (Minimal)
2.	Yum -y groupinstall “Development Tools”
3.	Yum -y install epel-release
4.	Yum -Y groupinstall “X Windows system”
5.	Yum -Y groupinstall “MATE Desktop”
Comment 5 Zane Zak 2016-12-21 23:16:07 EST
Getting this upgrading from CentOS 7.2 to 7.3. Same scenerio as Daniel above.
Comment 6 Andrew Gormanly 2016-12-22 11:09:01 EST
Steps to reproduce: yum upgrade

This breaks patching of boxes, and auto-patching, and as such the Severity should be at least Medium.
Comment 9 Daniel Needles 2016-12-23 11:06:16 EST
Awesome!  Thanks!!
Comment 10 Gordon Messmer 2016-12-28 01:05:33 EST
I tested the update and provided karma.  It looks like more karma is required before it is pushed to the updates tree.
Comment 11 Jim 2016-12-28 05:41:31 EST
(In reply to Daniel Needles from comment #4)
> I am seeing this problem when trying to set up MATE on CentOS 7.
> 
> To reproduce:
> 1.	Install CentOS 7.3.1611 (Minimal)
> 2.	Yum -y groupinstall “Development Tools”
> 3.	Yum -y install epel-release
> 4.	Yum -Y groupinstall “X Windows system”
> 5.	Yum -Y groupinstall “MATE Desktop”

Hi mate,

Changing my Epel repo to the testing branch let me install MATE.

https://fedoraproject.org/wiki/EPEL/testing
Turn on : 
yum-config-manager --enable epel-testing 
Turn off :
yum-config-manager --disable epel-testing

-Pork
Comment 12 Daniel Needles 2016-12-28 13:16:11 EST
Jim great workaround!  I skipped the module but that was not ideal.  In another note I think the "low" severity isn't warranted given the nature of the issue on EPEL production.  In most environments I've been in they would have rolled back the original change immediately rather than wait over a week for a patch.
Comment 13 Rafal Luzynski 2017-01-04 10:35:17 EST
The build mentioned in comment 8 has fixed the problem so please consider closing this bug report.
Comment 14 Trevor Hemsley 2017-02-08 11:44:37 EST
Fixed version has been available for some time.

Note You need to log in before you can comment on or make changes to this bug.