Bug 140643 - Firefox: "Import wizard" hangs.
Firefox: "Import wizard" hangs.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-23 18:08 EST by Adam Bowns
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-13 02:59:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Bowns 2004-11-23 18:08:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When I click the "Import... " option on the File menu, the import
wizard starts up and displays the "Import data and settings from"
screen. This screen contains the text "Import Preferences, Bookmarks,
History, Passwords and other data from:" and 3 buttons, Back (which
can't be clicked), Next and Cancel. When I click next nothing happens.
The only other functional element on the screen is the cancel button
(which works).

Version-Release number of selected component (if applicable):
firefox-1.0-2.fc3

How reproducible:
Always

Steps to Reproduce:
1. Start firefox
2. Click the file menu.
3. Choose "Import..."
4. When the import wizard screen comes up, click next.
    

Actual Results:  Nothing happens

Expected Results:  I should be taken to the next screen where I can
choose from where to import data.
Comment 1 Per Nystrom 2005-01-08 00:20:16 EST
I'm having the same problem.  Makes it a real pain to upgrade, since I
don't know any other way to import my saved passwords from Mozilla :(
Comment 2 Adam Bowns 2005-02-16 18:58:06 EST
I've checked this again several months on, and the bug is still here. I'm
guessing that this bug *should* be easy to fix (for someone who knows what
they're doing). I know it may seem trivial, but this bug can cause people a lot
of unnecessary hassle when upgrading their boxes.
Comment 3 Adam Bowns 2005-03-24 12:49:58 EST
I've checked this bug again with the latest errata release
(firefox-1.0.2-1.3.1), its still here, and still reproduceable in the same way.
Comment 4 Adam Bowns 2005-05-18 12:17:16 EDT
Bug still present in latest release, firefox-1.0.4-1.3.1
Comment 5 John Reiser 2005-06-15 15:47:00 EDT
In FC4, firefox-1.0.4-4 acted the same way for me (presented nothing to import,
and the Next button did nothing), _until_ I copied my former ~/.mozilla
directory to my new $HOME.  Then a 1-choice "Netscape 6,7 or Mozilla 1.x" entry
appeared, with the choice pre-selected, and clicking Next proceeded correctly. 
I chose to import everything (cookies, passwords, bookmarks), and so far cookies
and bookmarks work correctly; I haven't checked passwords yet.  (Imported
bookmarks have a new top-level ancestor "From Netscape 6/7/Mozilla".)

So, perhaps Firefox imports only from "known correct" former locations, which in
the case of mozilla is $HOME/.mozilla.
Comment 6 Adam Bowns 2006-03-02 14:47:25 EST
Bug still present in FC5 Test 3, adjusting version field to reflect this.
Comment 7 Matthew Miller 2007-04-06 15:24:20 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]

Note You need to log in before you can comment on or make changes to this bug.