Bug 140647 - megaraid -> megaraid_mbox name change not handled on upgrades
Summary: megaraid -> megaraid_mbox name change not handled on upgrades
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-23 23:57 UTC by Chris Ricker
Modified: 2015-01-04 22:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 06:23:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2004-11-23 23:57:49 UTC
I just upgraded a Dell PowerEdge 1600SC running FC2 to FC3. The
upgrade crashed and burned with a kernel panic in the reboot after the
upgrade

The problem is that this machine has a megaraid card. In FC2, that
used the megaraid driver. In FC3, that uses the megaraid_mbox driver.
Anaconda didn't fix /etc/modprobe.conf accordingly, so the initrd that
was generated lacked the required megaraid_mbox driver. Fixing
modprobe.conf from rescue mode and regenerating the initrd fixed the
problem

This will likely bite anyone upgrading < FC3 to FC3 with megaraid devices

Comment 1 Bill Nottingham 2004-11-28 20:29:00 UTC
megaraid2       SCSI    megaraid_mbox
megaraid        SCSI    megaraid_mbox

is in the upgrade list.

Is your card in the PCI listing for megaraid_mbox?

Comment 2 Chris Ricker 2004-11-28 23:31:12 UTC
I think so. It's

01:02.0 Class 0104: 101e:1960 (rev 02)
        Subsystem: 1028:0475
        Flags: bus master, medium devsel, latency 32, IRQ 185
        Memory at fcd00000 (32-bit, prefetchable) [size=64K]
        Expansion ROM at fce00000 [disabled] [size=64K]
        Capabilities: [80] Power Management version 2

which should match

alias:          pci:v0000101Ed00001960sv00001028sd00000475bc*sc*i*

right?

Comment 3 Bill Nottingham 2004-11-29 16:54:24 UTC
Hey, when did the kernel stop running the module upgrade program?

Chris, does running 'module_upgrade' by hand fix it?

Comment 4 Chris Ricker 2004-11-29 17:16:11 UTC
Yep. I changed /etc/modprobe.conf back to the old entry

alias scsi_hostadapter2 megaraid

ran module_upgrade, and it corrected it to

alias scsi_hostadapter2 megaraid_mbox


There's no module_upgrade anywhere in the RPM %post scripts for the
kernel that's on that box (kernel-smp-2.6.9-1.681_FC3)

Comment 5 Dave Jones 2005-02-24 06:23:49 UTC
ok, its a bit late, but this has been fixed for FC4.


Note You need to log in before you can comment on or make changes to this bug.