Bug 1406479 - Custom ODL role fails when isolating it from Neutron services
Summary: Custom ODL role fails when isolating it from Neutron services
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z1
: 10.0 (Newton)
Assignee: Tim Rozet
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks: 1258832
TreeView+ depends on / blocked
 
Reported: 2016-12-20 16:11 UTC by Tim Rozet
Modified: 2018-10-18 07:25 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.2.0-3.el7ost,puppet-tripleo-5.5.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2017-02-01 14:46:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0234 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 director Bug Fix Advisory 2017-02-01 19:44:43 UTC
OpenStack gerrit 413205 None None None 2016-12-21 06:01:37 UTC
OpenStack gerrit 417020 None None None 2017-01-09 12:04:53 UTC
Launchpad 1651499 None None None 2016-12-20 16:11:42 UTC

Description Tim Rozet 2016-12-20 16:11:42 UTC
Description of problem:
Custom role for OpenDaylight without Neutron API service fails due to coupled dependencies between ODL and the Neutron service which cause an isolated ODL role to fail deployment. The first is ODL service is invoking neutron services which really should be left up to the user to map based on custom roles. This needs to be removed. The second issue is Neutron ML2 config with OpenDaylight relies on knowing the heat parameters to be able to add the ML2 config. When OpenDaylight API service is isolated to its own role, the Controller Neutron ML2 service will not have the correct hiera variables to be able to configure ML2. The solution to this is to add those parameters to the OpenDaylight OVS service, which will also be used on the Controller.

Version-Release number of selected component (if applicable):


How reproducible:
Always if OpenDaylightApi service is configured only on a custom role without Neutron services.

Steps to Reproduce:
1.  Assign OpenDaylightApi to its own role.
2.  Deploy
3.

Actual results:
ML2 puppet config fails and OpenDaylightApi service fails while trying to configure neutron on the OpenDaylight role.

Expected results:
ML2 config should complete on Controller node (where Neutron is) and OpenDaylight node should not try to configure Neutron.

Additional info:

Comment 1 Nir Yechiel 2016-12-21 06:01:37 UTC
Change 413205 proposed to master, and will need to be cherry picked to Newton.

Comment 2 Nir Yechiel 2017-01-08 06:35:08 UTC
All changes are merged upstream in stable/newton

Comment 9 errata-xmlrpc 2017-02-01 14:46:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0234.html


Note You need to log in before you can comment on or make changes to this bug.