Bug 140657 - httx doesn't work on GB18030 locale.
httx doesn't work on GB18030 locale.
Status: CLOSED DUPLICATE of bug 168331
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: im-sdk (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
: i18n
Depends On:
Blocks: IIIMF
  Show dependency treegraph
Reported: 2004-11-23 20:09 EST by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-11-21 06:25:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2004-11-23 20:09:20 EST
Description of problem:
With httx, in GB18030 locale, it is not possible to start the LE
unlike other native locales such as GB2312, zh_TW.Big5, ja_JP.eucJP or

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.killall httx
2.killall htt
3.service iiim start
4.LANG=zh_CN.GB18030 &
5.LANG=zh_CN.GB18030 XMODIFIERS=@im=htt
Actual results:
Nothing Happen. Unable to input using IIIMF.

Expected results:
Able to input using IIIMF.

Additional info:
Comment 2 Akira TAGOH 2005-09-26 23:01:55 EDT
this is an important issue to ensure GB18030 support in the deployed systems.
Comment 6 Lawrence Lim 2005-11-11 02:13:58 EST
Verify the bug together with a few native encoding such as zh_CN.GB2312,
zh_TW.Big5, ja_JP.eucJP and ko_KR.eucKR confirm LE is working in GB18030 locale.
Comment 7 Qian Shen 2005-11-21 04:29:43 EST
Test this bug again. This bug does not exist in xorg with GB18030 patch.
Comment 8 Akira TAGOH 2005-11-21 06:25:56 EST
Qian, thank you for confirmation. this bug is a duplicate bug to Bug#168331 then.

*** This bug has been marked as a duplicate of 168331 ***
Comment 9 Jens Petersen 2006-02-09 22:16:31 EST
Removed from RHEL4U3CanFix based on last comment.

Note You need to log in before you can comment on or make changes to this bug.