Bug 140658 - Qt applications crash when Input Method not available
Summary: Qt applications crash when Input Method not available
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: IIIMF
TreeView+ depends on / blocked
 
Reported: 2004-11-24 01:23 UTC by Lawrence Lim
Modified: 2014-03-26 00:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-22 14:22:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace from the crash (1.52 KB, text/plain)
2004-11-24 04:17 UTC, Lawrence Lim
no flags Details

Description Lawrence Lim 2004-11-24 01:23:16 UTC
Description of problem:
In any event where httx shut down unexpectedly or crash, it will cause
any Qt application which has connection to, to crash.

Shutting down htt_server in GNOME desktop environment, with GTK
applications open does not cause the GTK applicatipons to crash.

Version-Release number of selected component (if applicable):
im-sdk-12.1-9.EL

How reproducible:
Always

Steps to Reproduce:
1.killall httx
2.killall htt
3.service iiim start
4.LANG=zh_CN.UTF-8 httx &
5.LANG=zh_CN.UTF-8 kedit &
6.kill -9 [pid of httx]
  
Actual results:
kedit crash

Expected results:
kedit should not crash

Additional info:

Comment 1 Leon Ho 2004-11-24 01:59:47 UTC
Is it a httx specific problem? does other XIM server work fine on that?

Comment 2 Lawrence Lim 2004-11-24 02:10:53 UTC
Thanks for pointing that out. :)

Tried with XIM server and yes, this is not httx specific as sending
SIGSEV to XIM server causes kedit to crash as well.

Comment 3 Lawrence Lim 2004-11-24 04:17:41 UTC
Created attachment 107377 [details]
backtrace from the crash

Comment 4 Ngo Than 2004-11-24 17:33:14 UTC
i have taken a look in backtrace, the crash happens in DestroyIC((XIC) ic)!
is it not a bug in xorg-x11? 

Comment 5 Leon Ho 2004-11-25 08:37:36 UTC
I am not sure because gtk+ calls DestroyIC() when XIM server closes as
well and it does not crash. AFAIS briefly, the destructor did check if
ic exists.

Comment 6 Ngo Than 2004-11-29 13:57:06 UTC
Leon, have you tried to contact to the qtimmodule author, YamaKen? i have sent
him an email but did not get any respond since a week.

Comment 7 Ngo Than 2005-02-22 14:22:42 UTC
it's fixed in qt-3.3.4-5, which will show up in rawhide soon


Note You need to log in before you can comment on or make changes to this bug.