Bug 1406746 - Upgrading to OSP11 fails with file transaction check error for openstack-dashboard-1 package
Summary: Upgrading to OSP11 fails with file transaction check error for openstack-dash...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: Upstream M3
: 11.0 (Ocata)
Assignee: Radomir Dopieralski
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-21 11:37 UTC by Marius Cornea
Modified: 2017-05-17 19:51 UTC (History)
16 users (show)

Fixed In Version: python-django-horizon-11.0.0-0.20170117082945.196cd93.1.el7ost
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-05-17 19:51:48 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Marius Cornea 2016-12-21 11:37:39 UTC
Description of problem:
Upgrading to OSP11 fails with file transaction check error for openstack-dashboard-1:

Transaction check error:
  file /usr/share/openstack-dashboard/openstack_dashboard/local/local_settings.d from install of openstack-dashboard-1:11.0.0-0.20161201021029.a187ea1.el7ost.noarch conflicts with file from package openstack-dashboard-1:10.0.1-4.el7ost.noarch


Version-Release number of selected component (if applicable):
openstack-dashboard-10.0.1-4.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP10
2. On overcloud nodes add OSP11 repos and run upgrade procedure

Actual results:
Upgrade fails during yum update with:

Transaction check error:
  file /usr/share/openstack-dashboard/openstack_dashboard/local/local_settings.d from install of openstack-dashboard-1:11.0.0-0.20161201021029.a187ea1.el7ost.noarch conflicts with file from package openstack-dashboard-1:10.0.1-4.el7ost.noarch


Expected results:
yum upgrade is able to proceed without errors

Additional info:
The openstack-dashboard version provided by OSP11 repos is openstack-dashboard.noarch 1:11.0.0-0.20161201021029.a187ea1.el7ost

Comment 1 Sofer Athlan-Guyot 2016-12-21 16:50:51 UTC
This looks a lot like:

https://bugzilla.redhat.com/show_bug.cgi?id=1361148

I'm adding Jon to the discussion as he fixed it for the previous release.

Comment 2 Jon Schlueter 2016-12-21 17:05:50 UTC
Likely initial build doesn't include packaging changes for downstream branding yet.  Also may have some potential to upstream even more of the packaging changes to avoid having to have conflicting .spec file changes for downstream branding to be carried.

Comment 3 Jason Guiditta 2016-12-21 18:51:32 UTC
(In reply to Jon Schlueter from comment #2)
> Likely initial build doesn't include packaging changes for downstream
> branding yet.  Also may have some potential to upstream even more of the
> packaging changes to avoid having to have conflicting .spec file changes for
> downstream branding to be carried.

Just a thought here, would there be any benefit to having a subpackage which depends on horizon that contains only the branding changes?  Maybe that would make it easier to maintain for future release?

Comment 4 Jon Schlueter 2017-01-05 15:10:11 UTC
openstack-dashboard is a sub-rpm for python-django-horizon

Comment 5 Radomir Dopieralski 2017-01-09 12:05:16 UTC
I have added the rhel-specific bits to the spec file.

Comment 7 Marius Cornea 2017-01-19 12:51:55 UTC
I'm still hitting this issue while trying to update to a newer version of python-django-horizon than the Fixed in version one:

## Existing version on OSP10
[root@overcloud-controller-0 ~]# rpm -qa | grep python-django-horizon
python-django-horizon-10.0.1-4.el7ost.noarch

## Update to the version provided by OSP11
[root@overcloud-controller-0 ~]# yum update -y python-django-horizon
Loaded plugins: product-id, search-disabled-repos, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package python-django-horizon.noarch 1:10.0.1-4.el7ost will be updated
--> Processing Dependency: python-django-horizon = 1:10.0.1-4.el7ost for package: 1:openstack-dashboard-10.0.1-4.el7ost.noarch
---> Package python-django-horizon.noarch 1:11.0.0-0.20170117082945.196cd93.el7ost will be an update
--> Running transaction check
---> Package openstack-dashboard.noarch 1:10.0.1-4.el7ost will be updated
--> Processing Dependency: openstack-dashboard = 1:10.0.1-4.el7ost for package: 1:openstack-dashboard-theme-10.0.1-4.el7ost.noarch
---> Package openstack-dashboard.noarch 1:11.0.0-0.20170117082945.196cd93.el7ost will be an update
--> Running transaction check
---> Package openstack-dashboard-theme.noarch 1:10.0.1-4.el7ost will be updated
---> Package openstack-dashboard-theme.noarch 1:11.0.0-0.20170117082945.196cd93.el7ost will be an update
--> Finished Dependency Resolution

Dependencies Resolved

===============================================================================================================================================================================================================================================
 Package                                                     Arch                                     Version                                                                      Repository                                             Size
===============================================================================================================================================================================================================================================
Updating:
 python-django-horizon                                       noarch                                   1:11.0.0-0.20170117082945.196cd93.el7ost                                     rhelosp-11.0-puddle                                   681 k
Updating for dependencies:
 openstack-dashboard                                         noarch                                   1:11.0.0-0.20170117082945.196cd93.el7ost                                     rhelosp-11.0-puddle                                    12 M
 openstack-dashboard-theme                                   noarch                                   1:11.0.0-0.20170117082945.196cd93.el7ost                                     rhelosp-11.0-puddle                                   1.9 k

Transaction Summary
===============================================================================================================================================================================================================================================
Upgrade  1 Package (+2 Dependent packages)

Total size: 12 M
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
  file /usr/share/openstack-dashboard/openstack_dashboard/local/local_settings.d from install of openstack-dashboard-1:11.0.0-0.20170117082945.196cd93.el7ost.noarch conflicts with file from package openstack-dashboard-1:10.0.1-4.el7ost.noarch

Error Summary
-------------

Comment 10 errata-xmlrpc 2017-05-17 19:51:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.