Bug 1406826 - Duplicate nova hypervisors show up in nova hypervisor-list post 10 -> 11 upgrade
Summary: Duplicate nova hypervisors show up in nova hypervisor-list post 10 -> 11 upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Marios Andreou
QA Contact: Marius Cornea
URL:
Whiteboard:
: 1425472 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-21 15:10 UTC by Marius Cornea
Modified: 2017-05-17 19:51 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1365789
Environment:
Last Closed: 2017-05-17 19:51:55 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Comment 1 Marius Cornea 2016-12-21 15:12:30 UTC
In OSP11 ComputeHostnameFormat is set to '%stackname%-novacompute-%index% so we'll most probably hit the same issue with it as in the past:

[stack@undercloud-0 ~]$ grep -A3 Compute /usr/share/openstack-tripleo-heat-templates/roles_data.yaml  | grep HostnameFormatDefault
  HostnameFormatDefault: '%stackname%-novacompute-%index%'

[stack@undercloud-0 ~]$ rpm -qa | grep tripleo-heat-templates
openstack-tripleo-heat-templates-6.0.0-0.20161130195427.9cd0c5a.el7ost.noarch

Comment 6 Marius Cornea 2017-02-23 14:39:14 UTC
*** Bug 1425472 has been marked as a duplicate of this bug. ***

Comment 7 Sofer Athlan-Guyot 2017-03-21 18:25:19 UTC
Putting this back to POST as it landed downstream.

Marius can you confirm that it has been release in latest puddle and is not an issue anymore.

Thanks,

Comment 8 Marius Cornea 2017-03-22 11:19:59 UTC
Yes, this is fixed in the latest puddle.

Comment 10 errata-xmlrpc 2017-05-17 19:51:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.