Bug 1406831 - Review Request: perl-Module-Install-DOAPChangeSets - Write your distribution change log in RDF
Summary: Review Request: perl-Module-Install-DOAPChangeSets - Write your distribution ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jitka Plesnikova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1406807
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-21 15:17 UTC by Petr Pisar
Modified: 2017-01-02 08:09 UTC (History)
2 users (show)

Fixed In Version: perl-Module-Install-DOAPChangeSets-0.206-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-02 08:09:41 UTC
Type: ---
jplesnik: fedora-review+


Attachments (Terms of Use)

Description Petr Pisar 2016-12-21 15:17:47 UTC
Spec URL: https://ppisar.fedorapeople.org/perl-Module-Install-DOAPChangeSets/perl-Module-Install-DOAPChangeSets.spec
SRPM URL: https://ppisar.fedorapeople.org/perl-Module-Install-DOAPChangeSets/perl-Module-Install-DOAPChangeSets-0.206-1.fc26.src.rpm
Description:
This package allows you to write your Changes file in Turtle or RDF/XML and
autogenerate a human-readable text file.

Fedora Account System Username: ppisar

Comment 1 Jitka Plesnikova 2016-12-22 14:55:33 UTC
Summary is ok
Description is ok
URL and Source0 are ok
All tests passed
BuildRequires are ok

$ rpm -qp --requires perl-Module-Install-DOAPChangeSets-0.206-1.fc26.noarch.rpm | sort | uniq -c
      1 perl(:MODULE_COMPAT_5.24.0)
      1 perl(:VERSION) >= 5.8.0
      1 perl(File::Slurp)
      1 perl(LWP::Simple)
      1 perl(List::MoreUtils)
      1 perl(Module::Install::Base)
      1 perl(Perl::Version)
      1 perl(RDF::DOAP::ChangeSets)
      1 perl(RDF::Query) >= 2.906
      1 perl(RDF::Trine) >= 0.112
      1 perl(Text::Wrap)
      1 perl(URI::file) >= 4.0
      1 perl(parent)
      1 perl(strict)
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
Binary requires are Ok.

$ rpm -qp --provides perl-Module-Install-DOAPChangeSets-0.206-1.fc26.noarch.rpm | sort | uniq -c
      1 perl(Module::Install::Admin::DOAPChangeSets) = 0.206
      1 perl(Module::Install::DOAPChangeSets) = 0.206
      1 perl(RDF::DOAP::ChangeSets) = 0.206
      1 perl-Module-Install-DOAPChangeSets = 0.206-1.fc26
Binary provides are Ok.

$ rpmlint ./perl-Module-Install-DOAPChangeSets*
perl-Module-Install-DOAPChangeSets.noarch: W: spelling-error %description -l en_US autogenerate -> auto generate, auto-generate, unregenerate
perl-Module-Install-DOAPChangeSets.src: W: spelling-error %description -l en_US autogenerate -> auto generate, auto-generate, unregenerate
2 packages and 1 specfiles checked; 0 errors, 2 warnings.

Rpmlint is ok

License
FIX: Please add license Public Domain (COPYRIGHT)

BuildRequires are almost ok
FIX: Please add 'coreutils' (spec file L54:rm -rf ./inc)

Please correct all 'FIX' issues.

Otherwise package looks good.
Approved.

Comment 2 Gwyn Ciesla 2016-12-23 13:48:14 UTC
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/rpms/perl-Module-Install-DOAPChangeSets

Comment 3 Petr Pisar 2017-01-02 08:09:41 UTC
Thank you for the review and the repository. I corrected the spec file.


Note You need to log in before you can comment on or make changes to this bug.