Bug 1406838 - memberOf fixup task does not validate args
Summary: memberOf fixup task does not validate args
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.4
Hardware: All
OS: All
unspecified
high
Target Milestone: rc
: ---
Assignee: Noriko Hosoi
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On: 1406835
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-21 15:29 UTC by mreynolds
Modified: 2017-08-01 21:12 UTC (History)
4 users (show)

Fixed In Version: 389-ds-base-1.3.6.1-3.el7
Doc Type: Bug Fix
Doc Text:
Bug: If an invalid base dn, or invalid filter was provided in the memberof fixup task, there was no way to tell that the task actually failed. Fix: It was fixed to log an error and properly update the task status/exit code, when an error occurs.
Clone Of: 1406835
Environment:
Last Closed: 2017-08-01 21:12:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2086 normal SHIPPED_LIVE 389-ds-base bug fix and enhancement update 2017-08-01 18:37:38 UTC

Description mreynolds 2016-12-21 15:29:54 UTC
+++ This bug was initially created as a clone of Bug #1406835 +++

Description of problem:

The filter and basedn of the memberOf fixup task are not validated.  If there is a problem it silently fails, and it's not obvious in the logs that the task failed.

How reproducible:

Run the memberOf fixup task using an invalid filter:

    '(objectclass=person'


Actual results:

The errors log shows that the task finished, but in fact it failed


Expected results:

The errors log, and task log, show that the task failed to run.


Upstream ticket:

https://fedorahosted.org/389/ticket/49072

Comment 1 mreynolds 2016-12-21 15:44:13 UTC
Fixed upstream

Comment 4 Sankar Ramalingam 2017-05-25 05:48:24 UTC
Marking it as Verified based on upstream tests.
====================== test session starts ========================
platform linux2 -- Python 2.7.5, pytest-3.1.0, py-1.4.33, pluggy-0.4.0 -- /usr/bin/python
cachedir: .cache
metadata: {'Python': '2.7.5', 'Platform': 'Linux-3.10.0-663.el7.x86_64-x86_64-with-redhat-7.4-Maipo', 'Packages': {'py': '1.4.33', 'pytest': '3.1.0', 'pluggy': '0.4.0'}, 'Plugins': {'beakerlib': '0.7.1', 'html': '1.14.2', 'cov': '2.5.1', 'metadata': '1.5.0'}}
DS build: 1.3.6.1
389-ds-base: 1.3.6.1-15.el7
nss: 3.28.4-8.el7
nspr: 4.13.1-1.0.el7_3
openldap: 2.4.44-4.el7
svrcore: 4.1.3-2.el7

rootdir: /mnt/tests/rhds/tests/upstream/ds/dirsrvtests/tests/tickets, inifile:
plugins: metadata-1.5.0, html-1.14.2, cov-2.5.1, beakerlib-0.7.1
collected 2 items 

ticket49072_test.py::test_ticket49072_basedn PASSED
ticket49072_test.py::test_ticket49072_filter PASSED

=================== 2 passed in 26.45 seconds =====================

Comment 5 errata-xmlrpc 2017-08-01 21:12:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2086


Note You need to log in before you can comment on or make changes to this bug.