Bug 140684 - Web Collage Screen Saver Inappropriate
Web Collage Screen Saver Inappropriate
Status: CLOSED DUPLICATE of bug 139513
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-24 02:57 EST by Matt Simpson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-09 16:16:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Simpson 2004-11-24 02:57:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
Not really a bug except in the sense of providing this feature...

In the KDE version of Xscreensaver (maybe Gnome also), the "Web
Collage" is enabled by default. This program grabs pictures from the
internet and displays them as the screensaver. The problem is a lot of
these pictures are inappropriate because they are sexual in content.
Imagine if this happened in an elementary school...

Secondly this program opens a port and uses tcp to search and download
things. This is a bad idea, especially when the user is not told this
up front.

The Web Collage screensaver should be removed or turned off by default.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Bring up KDE Control Center.
2.Select Appearance & Themes, then Screen Saver
3.Under Banners & Pictures select Web Collage.
    

Actual Results:  Pictures appeared, many sexual related.

Expected Results:  Since there is no way to filter the images, this
screensaver should not be allowed or enabled. It would be nice if you
could select Random and then disable this one (like in
xscreensaver-demo) but since thet is not allowed, the only alternative
is to either select 1 only or disable it in KDE and run xscreensaver
separately.

Additional info:
Comment 1 Sitsofe Wheeler 2004-11-24 03:38:42 EST
This is a dup of bug 139513
Comment 2 Ray Strode [halfline] 2005-09-09 16:16:57 EDT

*** This bug has been marked as a duplicate of 139513 ***

Note You need to log in before you can comment on or make changes to this bug.