Bug 1406873 - Base Runtime FTBFS: redland-1.0.17-7.fc25
Summary: Base Runtime FTBFS: redland-1.0.17-7.fc25
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: redland
Version: 25
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: BaseRuntimeFTBFS
TreeView+ depends on / blocked
 
Reported: 2016-12-21 17:38 UTC by Stephen Gallagher
Modified: 2016-12-25 01:50 UTC (History)
5 users (show)

Fixed In Version: redland-1.0.17-8.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-25 01:50:28 UTC
Type: Bug


Attachments (Terms of Use)
Patch to add BR on perl (1.59 KB, patch)
2016-12-21 17:38 UTC, Stephen Gallagher
rdieter: review+
Details | Diff

Description Stephen Gallagher 2016-12-21 17:38:28 UTC
Created attachment 1234463 [details]
Patch to add BR on perl

Description of problem:
When attempting to rebuild portions of the frozen package set of Fedora 25, we discovered that redland fails to build due to a missing BuildRequires on perl due to perl being removed from the default buildroot.

Version-Release number of selected component (if applicable):
redland-1.0.17-7.fc25

How reproducible:
Every time

Steps to Reproduce:
1. fedpkg clone redland
2. fedpkg switch-branch f25
3. fedpkg mock-build

Actual results:

make[3]: ./scripts/touch-mtime.pl: Command not found

Expected results:
Successful build of the package.

Additional info:
This is needed as part of the Base Runtime effort.

Please find attached a patch that adds the missing BuildRequires on perl.

If you feel it is acceptable, please pull it in and commit it to dist-git.

If you feel the patch is unacceptable, please respond within two weeks with an explanation of why. If we hear no response before then, a provenpackager will make the change so that we can unblock the Base Runtime effort.

Comment 1 Rex Dieter 2016-12-21 20:29:44 UTC
Comment on attachment 1234463 [details]
Patch to add BR on perl

ack on the patch, looks good

Comment 2 Rex Dieter 2016-12-21 20:32:48 UTC
patch applied

Comment 3 Fedora Update System 2016-12-21 20:56:18 UTC
redland-1.0.17-8.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-77cbdfd0e0

Comment 4 Fedora Update System 2016-12-22 19:20:27 UTC
redland-1.0.17-8.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-77cbdfd0e0

Comment 5 Fedora Update System 2016-12-25 01:50:28 UTC
redland-1.0.17-8.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.