Bug 140698 - iptraf looks terrible on linux console
iptraf looks terrible on linux console
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: iptraf (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-24 05:41 EST by Bernd Bartmann
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-01 02:50:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
IPTraf screen shot "broken" (4.79 KB, image/png)
2006-02-01 18:03 EST, Dean Earley
no flags Details

  None (edit)
Description Bernd Bartmann 2004-11-24 05:41:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
iptraf in FC3 looks terrible when run on the linux console. Something
seems to be broken here either in ncurses, locale or UTF-8. Everything
is fine in a gnome-terminal.

Here are my locale settings:

LANG="de_DE.UTF-8"
SUPPORTED="en_US.UTF-8:en_US:en:de_DE.UTF-8:de_DE:de"
SYSFONT="latarcyrheb-sun16"

Version-Release number of selected component (if applicable):
iptraf-2.7.0-11

How reproducible:
Always

Steps to Reproduce:
1. use a german system locale
2. run iptraf on the linux console
3.
    

Additional info:
Comment 1 Dean Earley 2005-08-10 19:06:47 EDT
This still seems to be an issue in FC4.
It happens both on the console (text) and over ssh with putty (in utf8 mode)

LANG="en_GB.UTF-8"
TERM="xterm"

I does however work fine in screen on both
Comment 2 Fedora Update System 2006-01-31 11:39:53 EST
From User-Agent: XML-RPC

iptraf-2.7.0-15.FC4.1 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 3 Dean Earley 2006-02-01 18:02:14 EST
This appears to still be an issue (or at least it looks exactly the same as it 
did before.

Running in putty, both with sudo and as root directly:
LANG="en_GB.UTF-8"
TERM="xterm"

I have attached a screen shot
Comment 4 Dean Earley 2006-02-01 18:03:09 EST
Created attachment 124012 [details]
IPTraf screen shot "broken"
Comment 5 Miroslav Lichvar 2006-02-02 07:12:49 EST
This is a bit different problem and I think it is putty's fault, for example
centericq in putty has the same broken frames.

Note You need to log in before you can comment on or make changes to this bug.