Bug 140701 - gamin-0.0.17-1.FC3 loops
gamin-0.0.17-1.FC3 loops
Status: CLOSED DUPLICATE of bug 132354
Product: Fedora
Classification: Fedora
Component: gamin (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-24 06:10 EST by Harald Hoyer
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-24 06:24:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2004-11-24 06:10:51 EST
PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 6223 harald    25   0  4532 1732 1992 R 99.9  0.2   1258:44 gam_server

gamin seems stuck in a loop

#0  0x00aa3335 in g_list_length () from /usr/lib/libglib-2.0.so.0
#1  0x0804ca57 in gam_poll_consume_subscriptions () at gam_poll.c:916
#2  0x0804ff04 in gam_dnotify_consume_subscriptions_real (data=0x0)
    at gam_dnotify.c:212
#3  0x00aa8a98 in g_child_watch_add () from /usr/lib/libglib-2.0.so.0
#4  0x00aa574b in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#5  0x00aa71d2 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#6  0x00aa747f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#7  0x0804aaf6 in main (argc=1, argv=0xfee54794) at gam_server.c:339
#8  0x00799e33 in __libc_start_main () from /lib/tls/libc.so.6
#9  0x08049f91 in _start ()

I can provide more debugging info, cause I have that thing stopped in gdb right now.
Comment 1 Daniel Veillard 2004-11-24 06:24:10 EST
It is a duplicate of an existing bug, but the stack trace is different,
If you could give an idea of the list of file names in the (looping)
subs list, that could help a bit,

thanks a lot for the information !

Daniel

*** This bug has been marked as a duplicate of 132354 ***

Note You need to log in before you can comment on or make changes to this bug.