Bug 140720 - "file" crashes intermittently
"file" crashes intermittently
Status: CLOSED DUPLICATE of bug 131892
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: file (Show other bugs)
4.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-24 09:24 EST by Johan Walles
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test case (169 bytes, application/octet-stream)
2004-11-24 09:25 EST, Johan Walles
no flags Details

  None (edit)
Description Johan Walles 2004-11-24 09:24:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; sv-SE; rv:1.6) Gecko/20040113

Description of problem:
Running "file" crashes about once in forty-two or so invocations.


Version-Release number of selected component (if applicable):
file-4.10-1

How reproducible:
Always

Steps to Reproduce:
while file /tmp/Lima ; do test ; done

Actual Results:  /tmp/Lima: data
/tmp/Lima: data
/tmp/Lima: data
/tmp/Lima: data
/tmp/Lima: data
Segmentation fault


Expected Results:  An infinite list of:
/tmp/Lima: data


Additional info:

Will attach my "Lima" file.  Pls bug me if I forget.

The segfault happens for me withing seconds on an SMP system.
Comment 1 Johan Walles 2004-11-24 09:25:33 EST
Created attachment 107389 [details]
Test case
Comment 2 Radek Vokal 2004-11-24 09:32:58 EST

*** This bug has been marked as a duplicate of 131892 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.