Bug 140726 - Case sensative boolean alias search results in software alias
Case sensative boolean alias search results in software alias
Status: CLOSED WORKSFORME
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
Mike MacKenzie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-24 10:09 EST by James Laska
Modified: 2013-09-02 02:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 15:28:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Laska 2004-11-24 10:09:38 EST
Basically a case insensative boolean search on the alias field works, however a
case sensative search doesn't.

https://bugzilla.redhat.com/beta/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=&component_text=&query_format=advanced&long_desc_type=substring&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&fixed_in_type=allwordssubstr&fixed_in=&qa_whiteboard_type=allwordssubstr&qa_whiteboard=&devel_whiteboard_type=allwordssubstr&devel_whiteboard=&keywords_type=allwords&keywords=&cust_facing=&cust_facing_type=substring&emailreporter1=1&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailcc2=1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&changedin=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=alias&type0-0-0=casesubstring&value0-0-0=RHEL4

results in:

Software error:

DBD::Pg::st execute failed: ERROR:  parser: parse error at or near "BINARY" at
character 490 [for Statement "SELECT bugs.bug_id, bugs.bug_severity,
bugs.priority, bugs.bug_status, bugs.resolution, bugs.alias, bugs.delta_ts,
bugs.bug_severity, bugs.priority, bugs.rep_platform, map_assigned_to.login_name,
bugs.bug_status, bugs.resolution, bugs.short_desc FROM bugs LEFT JOIN
bug_group_map  ON bug_group_map.bug_id = bugs.bug_id  LEFT JOIN cc ON cc.bug_id
= bugs.bug_id AND cc.who = 141215  , profiles AS map_assigned_to WHERE
bugs.assigned_to = map_assigned_to.userid AND (POSITION(CAST('RHEL4' AS BINARY)
IN CAST(bugs.alias AS BINARY)) != 0) AND ((bug_group_map.group_id IS NULL)  OR
bug_group_map.group_id IN
(33,34,22,4,78,75,68,44,2,12,67,76,3,41,25,15,58,21,35,7,62,61,17,11,72,50,71,5,38,39)
 OR (bugs.reporter_accessible = 1 AND bugs.reporter = 141215)  OR
(bugs.cclist_accessible = 1 AND cc.who IS NOT NULL)  OR (bugs.assigned_to =
141215)  OR (bugs.qa_contact = 141215) ) GROUP BY bugs.bug_id,
bugs.bug_id,bugs.bug_severity,bugs.priority,bugs.bug_status,bugs.resolution,bugs.alias,bugs.delta_ts,bugs.bug_severity,bugs.priority,bugs.rep_platform,map_assigned_to.login_name,bugs.bug_status,bugs.resolution,bugs.short_desc
ORDER BY
bugs.delta_ts,bugs.delta_ts,bugs.bug_status,bugs.priority,map_assigned_to.login_name,bugs.bug_id"]
at Bugzilla/DB.pm line 74
	Bugzilla::DB::SendSQL('SELECT bugs.bug_id, bugs.bug_severity, bugs.priority,
bugs.bu...') called at /var/www/bugzilla/beta/buglist.cgi line 614

For help, please send mail to the webmaster (bugzilla@redhat.com), giving this
error message and the time and date of the error.
Comment 1 David Lawrence 2006-04-08 13:47:24 EDT
Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
this version. Any bugs against the older versions will need to be verified that
they are still bugs. This will help me also to sort them better.
Comment 2 Bradley 2006-11-14 00:01:18 EST
Still happens, with a summary search.
Comment 3 David Lawrence 2008-09-16 12:51:35 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 4 Kevin Baker 2008-11-21 15:28:05 EST
Works for me.

Note You need to log in before you can comment on or make changes to this bug.