Bug 140727 - Some fence man pages excluded from Makefile
Some fence man pages excluded from Makefile
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: fence (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-24 10:15 EST by Derek Anderson
Modified: 2009-08-31 14:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 14:01:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Anderson 2004-11-24 10:15:26 EST
Description of problem:
Please add the following to cluster/fence/man/Makefile so they are
installed with the others:

fence_baytech.8
fence_bladecenter.8
fenced.8

Version-Release number of selected component (if applicable):
sources.redhat.com/cluster Nov 24, 2004

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam "mantis" Manthei 2004-11-24 10:58:49 EST
fence_baytech is still not a supported agent.  As such, it and its
manpage should not be included in the RPM.  It shouldn't hurt to
include it in the install target of the Makefile provided it remains
out of the RPM.
Comment 2 Chris Feist 2004-11-30 14:57:53 EST
This has been fixed in the source code and will be built into the next
fence RPM.  I didn't include fence_baytech in the 'make install'
because of problems when attempting to exclude the file from the RPM.
Comment 3 Derek Anderson 2005-01-11 10:01:16 EST
Chris,

The fence_bladecenter.8 can also be removed now since the agent has
been replaced with fence_ibmblade.  Other than that, OK.
Comment 4 Adam "mantis" Manthei 2005-01-11 16:43:11 EST
Not quite.

fence_bladecenter is the agent to ship.  It uses the telnet interface
of the bladecenter's management module to fence nodes.  This is the
agent we need to ship.

fence_ibmblade is the snmp agent that will not work with dlm setups, s
we are not supporting this one.

agents/Makefile/1.3.2.2/Mon Jan 10 22:16:06 2005//TRHEL4 and
man/Makefile/1.5.2.1/Mon Jan 10 22:14:17 2005//TRHEL4 are the correct
versions on the Makefiles.
Comment 5 Giuseppe Raimondi 2005-07-14 07:04:45 EDT
rpm -ql fence does not list any /sbin/fence_bladecenter, the man page is there
though.
Am I missing something here?
I'm slightly confused...
Do we actually ship (or wanted to ship) fence_bladecenter? If no why is the man
page there, if yes where is the binary?
Comment 6 Chris Feist 2005-07-14 10:13:53 EDT
Which version of fence are you using?
Comment 7 Giuseppe Raimondi 2005-07-14 10:26:08 EDT
I was just checking the latest one available via RHN.
Comment 8 Chris Feist 2005-07-14 10:46:01 EDT
The latest version of fence (1.32.4-0) contains the fix for this problem.

Note You need to log in before you can comment on or make changes to this bug.