Bug 140781 - grep-2.5.1-31.2 update
grep-2.5.1-31.2 update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grep (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-24 16:05 EST by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-16 12:15:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2004-11-24 16:05:58 EST
This is for:

 * correctness regressions compared to grep-2.5.1-31
 * performance regressions compared to grep-2.5.1-31
 * benchmark results
 * even a simple "installed it here and it seems to work"
Comment 1 Rob Hughes 2004-12-03 07:51:53 EST
grep -f and fgrep fail on binary files at 
 
 read(3, "eck\0freopen\0__wuflow\0re_search\0f"..., 12288) = 12288 
 open("/usr/lib/gconv/gconv-modules.cache", O_RDONLY) = 4 
 fstat64(4, {st_mode=S_IFREG|0644, st_size=21544, ...}) = 0 
 mmap2(NULL, 21544, PROT_READ, MAP_SHARED, 4, 0) = 0xf6ddc000 
 close(4) = 0 
  
And there is sits as long as I'm willing to wait (up to an hour so 
far). Doesn't matter whether I'm root or a user. Strings file|grep 
<something> doesn't show this problem, nor does it occur on ascii 
files. 
Comment 2 Tim Waugh 2004-12-03 08:11:02 EST
Thanks for the report.  This seems to be a regression relative to FC3.  Here is
the command line that reproduces it:

fgrep foo /bin/ex

(/bin/ex from vim-minimal-6.3.030-3)
Comment 3 Tim Waugh 2004-12-03 10:56:37 EST
Fixed package is grep-2.5.1-31.2.  Please re-test.  Thanks!
Comment 4 Rob Hughes 2004-12-03 11:08:43 EST
Works now. Thanks!
Comment 5 Rob Hughes 2004-12-03 11:15:41 EST
Just wanted to mention that grep_2.5.1-40_i386.rpm from rawhide shows the same 
regression.
Comment 6 Tim Waugh 2004-12-03 11:27:29 EST
Yes, I fixed rawhide at the same time.

Note You need to log in before you can comment on or make changes to this bug.