Bug 140783 - No ttcp in RHEL4.
Summary: No ttcp in RHEL4.
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-tools   
(Show other bugs)
Version: 4.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Radek Vokal
QA Contact: Ben Levenson
URL: ftp://ftp.sgi.com/sgi/src/ttcp/
Whiteboard:
Keywords: FutureFeature, Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-24 21:26 UTC by Carl Speare
Modified: 2008-08-27 09:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-27 09:12:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carl Speare 2004-11-24 21:26:37 UTC
Description of problem:
There is no ttcp in RHEL4. This utility provides excellent 
capabilities for testing network problems and enchancements. 
It would be a great addition.

Version-Release number of selected component (if applicable):
1.60-36

How reproducible:
Always.

Steps to Reproduce:
1. rpm -qipl on 'net-tools-1.60-36.x86_64.rpm'.
2. rpm -qipl on all RPMS, looking for 'ttcp' anywhere.
3. Nothing is found.
  
Actual results:
As above.

Expected results:
Would be nice to have /usr/sbin/ttcp.

Additional info:
Many enhanced versions exist besides the SGI version listed. I would 
suspect that a tool like this would be desirable in all 
distributions, include enterprise. (I have not checked if this exists 
in FC3, but I would expect it to be there at a minimum.)

Comment 1 Carl Speare 2004-11-24 22:49:56 UTC
Instead of ttcp, we might consider iperf:

http://dast.nlanr.net/Projects/Iperf/



Comment 2 Suzanne Hillman 2004-12-02 21:51:48 UTC
Internal RFE bug #141682 entered; will be considered for future releases.

Comment 3 Carl Speare 2005-08-12 18:09:41 UTC
Since I cannot access bug 141682 (internal only), is there any chance this case 
has been forgotten?

Comment 4 Suzanne Hillman 2005-08-24 17:03:56 UTC
This is unlikely to have been forgotten. However, if this is something for which
you have urgency, I would suggest talking to our support people, either by
calling 888-GO-REDHAT, or by logging in to http://www.redhat.com/support.

Comment 5 Carl Speare 2005-08-24 17:26:33 UTC
No urgency, thanks for the update!

Comment 6 Carl Speare 2007-03-29 00:32:39 UTC
It's been well over a year, and RHEL 4 update 4 doesn't contain ttcp or iperf.
Any chance it got considered for RHEL 5?

Comment 7 Carl Speare 2007-06-11 14:59:49 UTC
Now that RHEL 5 is out, should I be looking to see if iperf or ttcp is there?

Comment 8 Daniel Riek 2008-08-26 12:32:24 UTC
iperf is available from the EPEL repository for RHEL5, provided by the Fedora community. This means it is available, unsupported from Red Hat though. 

Generally I think that is sufficient for such a tool, but I would be interested in an RFE against RHEL6 with use-cases for these tools.

Comment 10 RHEL Product and Program Management 2008-08-26 12:40:21 UTC
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request.

Comment 11 Carl Speare 2008-08-26 16:55:57 UTC
Consider this an appeal. Tell me how I should generate an RFE and I will do so.

Alternatively, tell me what tool I should use to test TCP and UDP throughput. iperf is widely used for that purpose, and replaces ttcp. If there is a suggested alternative, I'm happy to hear it.

Comment 12 Zdenek Prikryl 2008-08-27 09:12:09 UTC
Fill up the new bug against RHEL6, component "distribution". Add the prefix "[REF]" to the bug name.


Note You need to log in before you can comment on or make changes to this bug.