Bug 140786 - irq problem (acpi related?) with USB pcmcia card and mini-pci wireless NIC
irq problem (acpi related?) with USB pcmcia card and mini-pci wireless NIC
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-24 16:44 EST by David Goldberg
Modified: 2015-01-04 17:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-27 13:50:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Goldberg 2004-11-24 16:44:19 EST
Description of problem:

irq problem when inserting a pcmcia USB 2.0 card

Version-Release number of selected component (if applicable):

All of 2.6.5-1.358, 2.6.8-1.521, 2.6.9-1.6_FC2

How reproducible:

Every time.

Steps to Reproduce:
1. Boot system.  kernel choice seems not to matter.  apm=off only
option specified.  That seemed to be necessary during install and was
carried into grub.conf from there.
2. Test network.  All is good.
3. Insert card.  See message in current terminal that IRQ 11 is
disabled.  
4. Test network.  Notice that mini-pci wireless card is now
disconnected from access point and nothing I've tried other than
rebooting without the pcmcia card brings it back.  
5. Plug usb device (external hard drive) into pcmcia card.  It is not
seen.

Actual results:

Neither pcmcia USB card nor wireless NIC work any more

Expected results:

Both devices should work

Additional info:

This is on a Dell 5100 laptop.  This worked under Core 1 and RH9
though in those cases I was using custom kernels to get the latest
acpi patches in and because I was dual booting at the time and needed
to enable NTFS.  Now that my laptop is M$-free I do not need to do
that any more.

The mini-pci is a Dell something that uses a broadcom chipset.  I use
the linuxant driverloader to support it.

Key message from dmesg suggests: 

irq 11: Please try booting with acpi=off and report a bug

Turning off acpi did not fix the problem though I have not checked
dmesg messages in that situation to see what else it might say.
Comment 1 David Goldberg 2005-03-20 21:59:22 EST
For what it's worth, the problem continues in Fedora Core 3.
Comment 2 Dave Jones 2005-04-16 00:15:39 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.
Comment 3 David Goldberg 2005-04-22 17:08:50 EDT
Still a problem in FC3.  I have upgraded to kernel 2.6.11-1.14_FC3 and also
tried to put irqpoll and irqfixup on the boot line.  One promising thing, using
those options, the card works OK (that is, USB works) if I boot with it in the
slot though the NIC still gets confused shortly after boot.  If I boot with the
card outside the slot and insert it, the card doesn't work properly (that is,
USB doesn't work) and the NIC loses as well.
Comment 4 David Goldberg 2005-06-26 22:35:17 EDT
May as well close it.  The card has now died and I don't plan on buying another.

Note You need to log in before you can comment on or make changes to this bug.