Bug 140805 - hald fails to load without messagebus
hald fails to load without messagebus
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
All Linux
medium Severity low
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-24 19:49 EST by Toma
Modified: 2013-03-05 22:42 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-03 14:22:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toma 2004-11-24 19:49:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
If you turn off messagebus in system-config-services, it fails to
recognise that hal wont work without it. Also fails to note that hal
wont work.

Version-Release number of selected component (if applicable):
hal-0.4.0-10

How reproducible:
Always

Steps to Reproduce:
1. turn off messagebus
2. try to start hald --verbose=yes
3.
    

Actual Results:  hald --verbose=yes --daemon=no
08:51:33.209 [I] hald.c:394: hal 0.4.0
08:51:33.211 [I] hald.c:398: Will not daemonize
08:51:33.213 [E] hald_dbus.c:1934: dbus_bus_get(): Failed to connect
to socket /var/run/dbus/system_bus_socket: Connection refused


Expected Results:  Alot of hald output.

Additional info:
Comment 1 David Zeuthen 2005-01-03 14:22:47 EST
The messagebus service is in fact started before the haldaemon service
so surely this is not a bug during normal use. In a future release
hald will be more verbose when it cannot connect to the messagebus.

Note You need to log in before you can comment on or make changes to this bug.