Bug 14081 - logrotate update should not change /etc/logrotate.conf
Summary: logrotate update should not change /etc/logrotate.conf
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: logrotate   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-16 20:08 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-16 20:08:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-07-16 20:08:44 UTC
every time i upgrade logrotate i have to go an manually
mv /etc/logrotate.conf.rpmsave /etc/logrotate.conf

the package should not assume i want my configuration
changed.

thanks
-dean

Comment 1 Erik Troan 2000-07-31 16:53:29 UTC
Is it generating an .rpmsave file that you're having to restore? How many times
has this
happened? Occasionally (well, twice) we've had to change the logrotate file in a
way
that made this happen (upgrading to 6.2 and 6.0 would have given this behavior),
so if that's
when you saw it, it's a feature, not a bug :-( Specifically, we removed lastlog
from rotation and 
fixed the permission of wtmp on rotation.

If you've seen this behavior more prevalently then this, please reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.