Bug 140813 - Unable to remove preedit buffer cleanly in Evolution Calendar
Unable to remove preedit buffer cleanly in Evolution Calendar
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: libgal2 (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
: i18n
Depends On:
Blocks: 154361 156322
  Show dependency treegraph
 
Reported: 2004-11-24 22:20 EST by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2005-556
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 10:44:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 303872 None None None Never

  None (edit)
Description Lawrence Lim 2004-11-24 22:20:25 EST
Description of problem:
In CJK locale, input characters in the predit buffers cannot be
removed completely when they are not committed. 

Version-Release number of selected component (if applicable):
evolution-2.0.2-5
evolution-data-server-devel-1.0.2-4
evolution-devel-2.0.2-5
evolution-data-server-1.0.2-4
evolution-webcal-1.0.10-1
evolution-connector-2.0.2-1

How reproducible:
Always

Steps to Reproduce:
1.from the g-t, run: LANG=ja_JP.UTF-8 evolution
2.click on calendar
3.single click on any time slot
4.ctrl-SPACE to enable Language Engine
5.enter 'sushi' 
6.use Backspace to remove the characters  

Actual results:
The first charcter cannot be removed

Expected results:
Everything should be removed.

Additional info:
Comment 1 Dave Malcolm 2005-01-20 17:04:31 EST
Stage 3 requires you to click on a timeslot containing an appointment,
otherwise you can't, see
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=131227#c4
Comment 2 Dave Malcolm 2005-01-20 17:08:50 EST
(best way to reproduce for me seems to be to delete all text in an
existing appointment, and then start stage 4)

This applies to the Day View, BTW
Comment 5 Dave Malcolm 2005-05-19 17:43:49 EDT
The patch in 154361 is working for me.
Comment 10 Dave Malcolm 2005-06-29 17:19:45 EDT
Correcting component to "libgal2"
Comment 16 Dave Malcolm 2005-08-02 22:10:42 EDT
Built with fix for RHEL4 as libgal2-2.2.3-6
Comment 17 Red Hat Bugzilla 2005-10-05 10:44:19 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-556.html

Note You need to log in before you can comment on or make changes to this bug.