Bug 140816 - 2.6.9-1.681_FC3 breaks USB sync with Kyocera 7135 Palm device
2.6.9-1.681_FC3 breaks USB sync with Kyocera 7135 Palm device
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-25 00:13 EST by Brian Daniels
Modified: 2015-01-04 17:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 20:13:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log entries during failed hotsync (1.36 KB, text/plain)
2004-11-25 00:14 EST, Brian Daniels
no flags Details

  None (edit)
Description Brian Daniels 2004-11-25 00:13:39 EST
Description of problem:
After yum-updating to 2.6.9-1.681_FC3 I can no longer sync over USB to
my Kyocera 7135 Smartphone (a PalmOS 4 device).  My sync script issues
the following commands:

export PILOTRATE=115200
pilot-xfer -p /etc/udev/devices/pilot -u /home/bdaniels/Pilot/backup

The sync starts but freezes after the first few files.  A few moments
later the 7135 announces a failed sync, and I then have to ctrl-c kill
the pilot-xfer.

I have tried reboots and reducing the PILOTRATE to 9600 without
success.  No errors are logged to /var/log/messages, just the usual
device connect/disconnect messages.  (I've attached a copy)

If I reboot back to 2.6.9-1.667, everything works fine again at the
original settings.

Version-Release number of selected component (if applicable):
2.6.9-1.681_FC3

How reproducible:
always

Steps to Reproduce:
1. Attempt usb hotsync with 2.6.9-1.681_FC3, fails
2. Reboot to 2.6.9-1.667
3. Repeat, hotsync is successful
  
Actual results:
Failed hotsync

Expected results:
Completed hotsync

Additional info:
Comment 1 Brian Daniels 2004-11-25 00:14:23 EST
Created attachment 107445 [details]
log entries during failed hotsync
Comment 2 Silvio Moioli 2004-11-27 03:50:07 EST
Same behaviour here, using Fedora Core 2, kernel 2.6.9-1.6_FC2, Palm
Tungsten T3 device. gpilotd would hang, and also the gnome panel
applet. With the 2.6.8-1.521 kernel everything worked fine.
Comment 3 Craig White 2004-12-05 01:28:40 EST
same problem as original poster - adding myself to list to be notified
of resolution - I am on i386
Comment 4 Daniel Thompson 2004-12-06 08:46:50 EST
This appears to be a dupe of 140125.
Comment 5 Dave Jones 2004-12-06 11:48:33 EST
fixed in the 698 kernel in updates-testing ?
Comment 6 Brian Daniels 2004-12-07 20:12:26 EST
>fixed in the 698 kernel in updates-testing ?

That seems to have fixed it, on the x86_64 arch at least.  My 7135 now
USB syncs without problems.  Thanks for the quick fix!

Comment 7 Russell Tokuyama 2004-12-17 16:25:00 EST
I have the same problem syncing my Handspring Deluxe with FC2
(2.6.9-1.6_FC2/i386) on an IBM ThinkPad A22p laptop.  My syslog
entries are similar to what has already been attached.  Another data
point is "pilot-xfer -l" will list the databases but hang after that.
 YADP, dlpsh commands df, user, and time work without hanging the
connection and the quit command will close the connection.  However,
the dlpsh ls command will list the databases and hang.
Comment 8 Russell Tokuyama 2004-12-18 16:24:39 EST
Installing 2.6.9-1.9_FC2/i686 from updates-testing on my IBM ThinkPad
A22p laptop cured the sync problem.  pilot-xfer and dlpsh both work
correctly without hanging.  As a side note, however, when I shutdown
2.69-1.9_FC2 did a kernel panic and froze the laptop.
Comment 9 Dave Jones 2004-12-18 21:39:20 EST
can you open a seperate bugzilla with that oops output please ?
Comment 10 Russell Tokuyama 2004-12-23 17:10:20 EST
Added oops info to 142774 before seeing Dave's comment.  Still want a
separate bug?

Note You need to log in before you can comment on or make changes to this bug.