Bug 1408195 - Bodhi has too verbose output by default
Summary: Bodhi has too verbose output by default
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: bodhi
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-22 12:26 UTC by Lukas Slebodnik
Modified: 2016-12-23 17:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-23 17:32:28 UTC


Attachments (Terms of Use)

Description Lukas Slebodnik 2016-12-22 12:26:45 UTC
Description of problem:
I would appreciate if output of bodhi would be less verbose by default.
I needn't see an internal structures by default.

Version-Release number of selected component (if applicable):
sh$ rpm -q bodhi-client 
bodhi-client-2.3.3-1.fc26.noarch

How reproducible:
Deterministic

Steps to Reproduce:
1. //try to change state of some package in fedora from command line
sh$ bodhi updates request --user lslebodn sssd-1.14.2-2.fc24 stable

Actual results:
Munch({u'update': Munch({u'date_testing': u'2016-12-15 03:52:12', u'old_updateid': None, u'pushed': True, u'require_testcases': True, u'date_locked': None, u'critpath': False, u'date_approved': None, u'stable_karma': 6, u'date_pushed': u'2016-12-15 03:52:12', u'requirements': u'', u'severity': u'unspecified', u'autokarma': True, u'title': u'sssd-1.14.2-2.fc24', u'suggest': u'unspecified', u'require_bugs': True, u'comments': [Munch({u'bug_feedback': [], u'user_id': 91, u'timestamp': u'2016-12-13 20:09:44', u'testcase_feedback': [], u'karma_critpath': 0, u'update_id': 75333, u'karma': 0, u'anonymous': False, u'text': u'This update has been submitted for testing by lslebodn. ', u'id': 535779, u'user': Munch({u'openid': u'bodhi.id.fedoraproject.org', u'name': u'bodhi', u'show_popups': True, u'id': 91, u'avatar': u'https://apps.fedoraproject.org/img/icons/bodhi-24.png', u'groups': [], u'email': None})}), Munch({u'bug_feedback': [], u'user_id': 91, u'timestamp': u'2016-12-15 05:04:50', u'testcase_feedback': [], u'karma_critpath': 0, u'update_id': 75333, u'karma': 0, u'anonymous': False, u'text': u'This update has been pushed to testing.', u'id': 536622, u'user': Munch({u'openid': u'bodhi.id.fedoraproject.org', u'name': u'bodhi', u'show_popups': True, u'id': 91, u'avatar': u'https://apps.fedoraproject.org/img/icons/bodhi-24.png', u'groups': [], u'email': None})}), Munch({u'bug_feedback': [], u'user_id': 124, u'timestamp': u'2016-12-15 23:31:15', u'testcase_feedback': [], u'karma_critpath': 0, u'update_id': 75333, u'karma': 1, u'anonymous': False, u'text': u'no regressions noted', u'id': 537104, u'user': Munch({u'openid': u'filiperosset.id.fedoraproject.org', u'name': u'filiperosset', u'show_popups': True, u'id': 124, u'avatar': u'https://seccdn.libravatar.org/avatar/d826994e83ce867281f73d85986dd475938841874b75a83a82cdb184f6af8749?s=24&d=retro', u'groups': [Munch({u'name': u'proventesters'}), Munch({u'name': u'provenpackager'}), Munch({u'name': u'packager'})], u'email': u'rosset.filipe@gmail.com'})}), Munch({u'bug_feedback': [], u'user_id': 91, u'timestamp': u'2016-12-22 06:00:24', u'testcase_feedback': [], u'karma_critpath': 0, u'update_id': 75333, u'karma': 0, u'anonymous': False, u'text': u'This update has reached 7 days in testing and can be pushed to stable now if the maintainer wishes', u'id': 540248, u'user': Munch({u'openid': u'bodhi.id.fedoraproject.org', u'name': u'bodhi', u'show_popups': True, u'id': 91, u'avatar': u'https://apps.fedoraproject.org/img/icons/bodhi-24.png', u'groups': [], u'email': None})}), Munch({u'bug_feedback': [], u'user_id': 91, u'timestamp': u'2016-12-22 12:09:53', u'testcase_feedback': [], u'karma_critpath': 0, u'update_id': 75333, u'karma': 0, u'anonymous': False, u'text': u'This update has been submitted for stable by lslebodn. ', u'id': 540366, u'user': Munch({u'openid': u'bodhi.id.fedoraproject.org', u'name': u'bodhi', u'show_popups': True, u'id': 91, u'avatar': u'https://apps.fedoraproject.org/img/icons/bodhi-24.png', u'groups': [], u'email': None})})], u'updateid': u'FEDORA-2016-b04d690b49', u'type': u'bugfix', u'close_bugs': True, u'meets_testing_requirements': True, u'date_submitted': u'2016-12-13 20:09:44', u'unstable_karma': -3, u'submitter': u'lslebodn', u'user': Munch({u'openid': u'lslebodn.id.fedoraproject.org', u'name': u'lslebodn', u'show_popups': True, u'id': 809, u'avatar': u'https://seccdn.libravatar.org/avatar/d69b9b24da4213d1e018fe681e71da6502aaffc989b60b2c5c4d1082dca77ab1?s=24&d=retro', u'groups': [Munch({u'name': u'packager'})], u'email': u'lslebodn@redhat.com'}), u'locked': False, u'builds': [Munch({u'epoch': 0, u'nvr': u'sssd-1.14.2-2.fc24', u'signed': True})], u'date_modified': None, u'url': u'https://bodhi.fedoraproject.org/updates/FEDORA-2016-b04d690b49', u'test_cases': [], u'notes': u"- rhbz#1369130 - nss_sss should not link against libpthread\n- rhbz#1392916 - sssd failes to start after updat- rhbz#1398789 - SELinux is preventing sssd from 'write' accessess on the directory /etc/sssd\n", u'request': u'stable', u'bugs': [Munch({u'bug_id': 1398789, u'security': False, u'feedback': [Munch({u'bug_id': 1398789, u'comment': Munch({u'user_id': 198, u'timestamp': u'2016-12-16 21:16:18', u'testcase_feedback': [], u'karma_critpath': 1, u'update_id': 75332, u'karma': 1, u'anonymous': False, u'text': u'Works here against LDAP/krb5 and AD backends on x86_64.', u'id': 537878, u'user': Munch({u'openid': u'bojan.id.fedoraproject.org', u'name': u'bojan', u'show_popups': True, u'id': 198, u'avatar': u'https://seccdn.libravatar.org/avatar/1a8afd83231ef5ba905344806ba95b39f2abd77b399b0ee217ec3e6fa30a4825?s=24&d=retro', u'groups': [Munch({u'name': u'packager'})], u'email': u'bojan@rexursive.com'})}), u'comment_id': 537878, u'karma': 0}), Munch({u'bug_id': 1398789, u'comment': Munch({u'user_id': 3125, u'timestamp': u'2016-12-18 16:31:29', u'testcase_feedback': [], u'karma_critpath': 1, u'update_id': 75332, u'karma': 1, u'anonymous': False, u'text': u'Works for me', u'id': 538487, u'user': Munch({u'openid': u'sikevux.id.fedoraproject.org', u'name': u'sikevux', u'show_popups': True, u'id': 3125, u'avatar': u'https://seccdn.libravatar.org/avatar/c51bb72d5a0dbf541ce610b3efc4319f69c8d4664a94055c88c78ae1d3da9bc8?s=24&d=retro', u'groups': [], u'email': u'sikevux@sikevux.se'})}), u'comment_id': 538487, u'karma': 1})], u'parent': False, u'title': u"SELinux is preventing sssd from 'write' accesses on the directory /etc/sssd."}), Munch({u'bug_id': 1392916, u'security': False, u'feedback': [Munch({u'bug_id': 1392916, u'comment': Munch({u'user_id': 198, u'timestamp': u'2016-12-16 21:16:18', u'testcase_feedback': [], u'karma_critpath': 1, u'update_id': 75332, u'karma': 1, u'anonymous': False, u'text': u'Works here against LDAP/krb5 and AD backends on x86_64.', u'id': 537878, u'user': Munch({u'openid': u'bojan.id.fedoraproject.org', u'name': u'bojan', u'show_popups': True, u'id': 198, u'avatar': u'https://seccdn.libravatar.org/avatar/1a8afd83231ef5ba905344806ba95b39f2abd77b399b0ee217ec3e6fa30a4825?s=24&d=retro', u'groups': [Munch({u'name': u'packager'})], u'email': u'bojan@rexursive.com'})}), u'comment_id': 537878, u'karma': 0}), Munch({u'bug_id': 1392916, u'comment': Munch({u'user_id': 3125, u'timestamp': u'2016-12-18 16:31:29', u'testcase_feedback': [], u'karma_critpath': 1, u'update_id': 75332, u'karma': 1, u'anonymous': False, u'text': u'Works for me', u'id': 538487, u'user': Munch({u'openid': u'sikevux.id.fedoraproject.org', u'name': u'sikevux', u'show_popups': True, u'id': 3125, u'avatar': u'https://seccdn.libravatar.org/avatar/c51bb72d5a0dbf541ce610b3efc4319f69c8d4664a94055c88c78ae1d3da9bc8?s=24&d=retro', u'groups': [], u'email': u'sikevux@sikevux.se'})}), u'comment_id': 538487, u'karma': 1})], u'parent': False, u'title': u'sssd failes to start after update'}), Munch({u'bug_id': 1369130, u'security': False, u'feedback': [Munch({u'bug_id': 1369130, u'comment': Munch({u'user_id': 198, u'timestamp': u'2016-12-16 21:16:18', u'testcase_feedback': [], u'karma_critpath': 1, u'update_id': 75332, u'karma': 1, u'anonymous': False, u'text': u'Works here against LDAP/krb5 and AD backends on x86_64.', u'id': 537878, u'user': Munch({u'openid': u'bojan.id.fedoraproject.org', u'name': u'bojan', u'show_popups': True, u'id': 198, u'avatar': u'https://seccdn.libravatar.org/avatar/1a8afd83231ef5ba905344806ba95b39f2abd77b399b0ee217ec3e6fa30a4825?s=24&d=retro', u'groups': [Munch({u'name': u'packager'})], u'email': u'bojan@rexursive.com'})}), u'comment_id': 537878, u'karma': 0}), Munch({u'bug_id': 1369130, u'comment': Munch({u'user_id': 3125, u'timestamp': u'2016-12-18 16:31:29', u'testcase_feedback': [], u'karma_critpath': 1, u'update_id': 75332, u'karma': 1, u'anonymous': False, u'text': u'Works for me', u'id': 538487, u'user': Munch({u'openid': u'sikevux.id.fedoraproject.org', u'name': u'sikevux', u'show_popups': True, u'id': 3125, u'avatar': u'https://seccdn.libravatar.org/avatar/c51bb72d5a0dbf541ce610b3efc4319f69c8d4664a94055c88c78ae1d3da9bc8?s=24&d=retro', u'groups': [], u'email': u'sikevux@sikevux.se'})}), u'comment_id': 538487, u'karma': 0})], u'parent': False, u'title': u'nss_sss should not link against libpthread'})], u'alias': u'FEDORA-2016-b04d690b49', u'status': u'testing', u'karma': 1, u'release': Munch({u'dist_tag': u'f24', u'name': u'F24', u'testing_tag': u'f24-updates-testing', u'pending_stable_tag': u'f24-updates-pending', u'pending_signing_tag': u'f24-signing-pending', u'long_name': u'Fedora 24', u'state': u'current', u'version': u'24', u'override_tag': u'f24-override', u'branch': u'f24', u'id_prefix': u'FEDORA', u'pending_testing_tag': u'f24-updates-testing-pending', u'stable_tag': u'f24-updates', u'candidate_tag': u'f24-updates-candidate'}), u'date_stable': None})})
================================================================================
     sssd-1.14.2-2.fc24
================================================================================
  Update ID: FEDORA-2016-b04d690b49
    Release: Fedora 24
     Status: testing
       Type: bugfix
      Karma: 1
    Request: stable
       Bugs: 1398789 - SELinux is preventing sssd from 'write' accesses on the
           : directory /etc/sssd.
           : 1392916 - sssd failes to start after update
           : 1369130 - nss_sss should not link against libpthread
      Notes: - rhbz#1369130 - nss_sss should not link against libpthread -
           : rhbz#1392916 - sssd failes to start after updat-
           : rhbz#1398789 - SELinux is preventing sssd from 'write'
           : accessess on the directory /etc/sssd
  Submitter: lslebodn
  Submitted: 2016-12-13 20:09:44
   Comments: bodhi - 2016-12-13 20:09:44 (karma 0)
             This update has been submitted for testing by
             lslebodn.
             bodhi - 2016-12-15 05:04:50 (karma 0)
             This update has been pushed to testing.
             filiperosset - 2016-12-15 23:31:15 (karma 1)
             no regressions noted
             bodhi - 2016-12-22 06:00:24 (karma 0)
             This update has reached 7 days in testing and can be
             pushed to stable now if the maintainer wishes
             bodhi - 2016-12-22 12:09:53 (karma 0)
             This update has been submitted for stable by lslebodn.

  https://bodhi.fedoraproject.org/updates/FEDORA-2016-b04d690b49
Expected results:
//only useful human readable output should be printed. 

================================================================================
     sssd-1.14.2-2.fc24
================================================================================
  Update ID: FEDORA-2016-b04d690b49
    Release: Fedora 24
     Status: testing
       Type: bugfix
      Karma: 1
    Request: stable
       Bugs: 1398789 - SELinux is preventing sssd from 'write' accesses on the
           : directory /etc/sssd.
           : 1392916 - sssd failes to start after update
           : 1369130 - nss_sss should not link against libpthread
      Notes: - rhbz#1369130 - nss_sss should not link against libpthread -
           : rhbz#1392916 - sssd failes to start after updat-
           : rhbz#1398789 - SELinux is preventing sssd from 'write'
           : accessess on the directory /etc/sssd
  Submitter: lslebodn
  Submitted: 2016-12-13 20:09:44
   Comments: bodhi - 2016-12-13 20:09:44 (karma 0)
             This update has been submitted for testing by
             lslebodn.
             bodhi - 2016-12-15 05:04:50 (karma 0)
             This update has been pushed to testing.
             filiperosset - 2016-12-15 23:31:15 (karma 1)
             no regressions noted
             bodhi - 2016-12-22 06:00:24 (karma 0)
             This update has reached 7 days in testing and can be
             pushed to stable now if the maintainer wishes
             bodhi - 2016-12-22 12:09:53 (karma 0)
             This update has been submitted for stable by lslebodn.

  https://bodhi.fedoraproject.org/updates/FEDORA-2016-b04d690b49

Comment 1 Randy Barlow 2016-12-23 17:32:28 UTC
Ah, looks like there's a stray print statement in there. I've fixed this in a PR:

https://github.com/fedora-infra/bodhi/pull/1184

We should be able to get that into the upcoming 2.4.0 release. Thanks for the report!


Note You need to log in before you can comment on or make changes to this bug.