Bug 14082 - text installer crashes after selecting "Disk Druid"
text installer crashes after selecting "Disk Druid"
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-16 16:51 EDT by Christian Rose
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-20 21:19:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2000-07-16 16:51:06 EDT
I run the text install (using Erik's new boot disk or the old image on the
cdrom doesn't matter), select Swedish as the language, se-latin1 as the
keyboard.
Then I choose "Install custom system", and then, when selecting what
formatting tool I want to use; directly after I've selected Disk Druid and
hit enter, the installer crashes, leaving the background blue and
outputting:

install exited abnormally -- recieved signal 11
sending termination signals...done
sending kill signals...done
<F1> for help | <Tab> between elements disabling swap... | <F12> next
screen...
unmounting filesystems...
/mnt/runtime
/mnt/source umount failed (16)
/dev/pts
/proc
you may safely reboot your system

Yes, that <F1> string appears mixed with those messages. Everything else is
a blue screen.

This happens every time I run the beta3 text installer and on the same spot
every time, but it doesn't happen when I use the graphical install.
Comment 1 Matt Wilson 2000-07-16 17:00:10 EDT
Tell me about your hardware, especially drive configuration.

Comment 2 Christian Rose 2000-07-16 17:18:35 EDT
General hardware info:

CPU:		Pentium 233 MMX
Memory:		96 MB
Disks:		600 MB IDE       (/ 436 MB, swap 64 MB)
		100 MB IDE
Cdrom:		24x
Video:		Matrox Mystique
NIC:		Intel Etherexpress 100+
Mouse:		Regular two-button PS/2

The 600 MB drive (reports as an IBM DALA-3540 in BIOS) is the primary master. No
further drives on the primary channel.
The 100 MB disk sits in a removable drive cage on the secondary channel, and
should be configured as primary, slave present. I can completely remove this
drive, and the bug still occurs.
The CD is on the secondary channel without any jumpering (should be slaving just
fine like it did in beta2).

I haven't had this bug with beta2.
Comment 3 Glen Foster 2000-07-18 16:38:30 EDT
This defect is considered MUST-FIX for Winston Beta-5
Comment 4 Michael Fulbright 2000-07-20 21:19:54 EDT
This was a known problem in glibc which is fixed in beta 4. Please try again
with beta 4 or 5, and let me know if it is still broken (it works fine here).
Comment 5 Christian Rose 2000-07-22 20:51:05 EDT
This doesn't happen in beta4 anymore.
I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.