Bug 140828 - Corrupted graphics display
Corrupted graphics display
Status: CLOSED DUPLICATE of bug 132267
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-25 04:55 EST by John Summerfield
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Summerfield 2004-11-25 04:55:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
This is a Pentium III system built with an Intel motherboard, Product
Name: D815EEA.

It has onboard graphics: 0000:00:02.0 VGA compatible controller: Intel
Corp. 82815 CGC [Chipset Graphics Controller] (rev 02)


I also have an HP evectra built on an i810 chipset, again with onboard
graphics.

Both have display problems in X (which means Anaconda). I've not yet
got and RH linux onto this system, its running Mandrake 10CE and
before that SuSE 9.1. Both of those also have display problems though
not as serious as the pictures at http://redhat.cds.merseine.nu/

On the evectra, rhgb also has problems.

If you look at the second image you will see the display is offset to
one side. That occurrs with all the above distros on this system, and
on the evecra in X and rhgb.

I'm sure that Anaconda isn't the best product to report against; I
suggest you assign sometone to take care of it, maybe open a new bug
and let me know.

The display problems depend on chosen resultion, and at some the
display is (somewhat) usable.


Version-Release number of selected component (if applicable):
Whatever

How reproducible:
Always

Steps to Reproduce:
1.Boot Nahant with VGA=791
2.Process to graphics display
3.Admire http://redhat.cds.merseine.nu/imgp0003.jpg
    

Actual Results:  Grossly distored screen with a vulgar vertical pattern.

Expected Results:  Readable, usable display

Additional info:

pcilib: Cannot open /sys/bus/pci/devices
0000:00:00.0 Host bridge: Intel Corp. 82815 815 Chipset Host Bridge
and Memory Controller Hub (rev 02)
0000:00:02.0 VGA compatible controller: Intel Corp. 82815 CGC [Chipset
Graphics Controller] (rev 02)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 01)
0000:00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 01)
0000:00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 01)
0000:00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 01)
0000:00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 01)
0000:00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 01)
0000:01:07.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97]
(rev 08)
0000:01:0b.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro
100] (rev 0c)
Comment 1 John Summerfield 2004-11-25 08:21:49 EST
I've add to that website kernel messages _from booting Mandrake_ plus
PCI and DMI info for the Intel dt system.
Comment 2 Mike A. Harris 2004-11-25 16:40:26 EST
Problem is widely reported in Fedora Core 3, which shares the
same Xorg release.  Fixed internally in CVS.  Will be in a future
FC3 update, and will be in the next official RHEL4 build.

Closing as duplicate of the master FC3 bug.  If the problem occurs
with build -19.EL or higher, please reopen.

*** This bug has been marked as a duplicate of 132267 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.