Bug 140834 - AttributeError: HTTPResponse instance has no attribute 'code'
AttributeError: HTTPResponse instance has no attribute 'code'
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-25 07:26 EST by Oliver Falk
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 10:13:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2004-11-25 07:26:33 EST
Description of problem:
[root@pils etc]# yum check-update
Traceback (most recent call last):
  File "/usr/bin/yum", line 8, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 51, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 133, in getOptionsConfig
    self.conf = yumconf(configfile = yumconffile, root=root)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 87, in
__init__
    self.cfg.readfp(configh)
  File "/usr/lib/python2.4/ConfigParser.py", line 286, in readfp
    self._read(fp, filename)
  File "/usr/lib/python2.4/ConfigParser.py", line 430, in _read
    line = fp.readline()
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 560, in
readline
    fo = self._pushfile( url )
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 604, in
_pushfile
    fo = self._urlresolver.urlopen(absurl)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
427, in urlopen
    return default_grabber.urlopen(url, **kwargs)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
555, in urlopen
    return self._retry(opts, retryfunc, url)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
527, in _retry
    return apply(func, (opts,) + args, {})
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
554, in retryfunc
    return URLGrabberFileObject(url, filename=None, opts=opts)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
703, in __init__
    self._do_open()
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
747, in _do_open
    fo, hdr = self._make_request(req, opener)
  File "/usr/lib/python2.4/site-packages/urlgrabber/grabber.py", line
823, in _make_request
    fo = opener.open(req)
  File "/usr/lib/python2.4/urllib2.py", line 364, in open
    response = meth(req, response)
  File "/usr/lib/python2.4/urllib2.py", line 468, in http_response
    code, msg, hdrs = response.code, response.msg, response.info()
AttributeError: HTTPResponse instance has no attribute 'code'

Version-Release number of selected component (if applicable):
2.1.11-4

How reproducible:
Always

Steps to Reproduce:
This happens since I updated to python 2.4, so it's maybe a python
bug, but one that yum should be aware of, dont' you think?

It happens if repositories are on http:// rather than on ftp:// as
well as include=http://...
Comment 1 Oliver Falk 2004-11-25 07:30:00 EST
Added this bug also for python; See bug #140835.
Comment 2 Seth Vidal 2004-11-25 10:13:05 EST
This is not a bug in yum.
Closing.

Note You need to log in before you can comment on or make changes to this bug.