Bug 140838 - stock fc3 rpm produces 272 lines of error messages when run
stock fc3 rpm produces 272 lines of error messages when run
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-25 08:08 EST by Wesley Tanaka
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 22:35:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wesley Tanaka 2004-11-25 08:08:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:

This occurred after an upgrade from fc2

The errors in question can be viewed at:
http://ofb.net/~wtanaka/linux/fc3.php#rpm

 I ran strace on rpm to see where the problem was coming from

   strace rpm --verify bash 2>&1 | grep '^open' | grep -v ENOENT | cut
-d\" -f2 | xargs grep policy | grep tree


It pointed at /usr/lib/rpm/macros which is part of the rpm package. I
ran rpm --verify rpm to make sure that the package was unmodified, and
it turned out that /usr/lib/rpm/rpmrc was modified. Since there was no
.rpmnew file lying around, I downloaded a new copy of the rpm rpm, and
installed it with: rpm -Uvh --force rpm-4.3.2-21.i386.rpm 

rpm --verify rpm
appears to verify that the package is indeed the stock rpm-4.3.2-21
package with no files modified, and the errors still occur.


Version-Release number of selected component (if applicable):
rpm-4.3.2-21

How reproducible:
Always

Steps to Reproduce:
Not sure how to reproduce, but I came across this immediately after
upgrading from fc2 to fc3.

Certain rpm commands, such as "rpm --verify rpm" (but not rpm -q rpm
or rpm --help) produce the errors.

Actual Results:  Lots of output on stderr

Expected Results:  No output on stderr
Comment 1 Jeff Johnson 2004-11-25 09:41:44 EST
Did you upgrade all the rpm packages from only fc3?

The error message is from an rpmlib w/o lua support,
look for a librpm-4.3.1 package that needs to be removed.
Comment 2 Wesley Tanaka 2004-11-25 22:35:32 EST
Thanks!  I messed up -- I should have checked the packages for all the
libraries that rpm opened as well.  I upgraded librpm4.3 from atrpms
and the errors go away.

Note You need to log in before you can comment on or make changes to this bug.