Bug 1408425 - Remove the kubectl CLI option from the deployment option and make OC as the default
Summary: Remove the kubectl CLI option from the deployment option and make OC as the d...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: cns-deploy-tool
Version: cns-3.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: CNS 3.5
Assignee: Ramakrishna Reddy Yekulla
QA Contact: Prasanth
URL:
Whiteboard:
Depends On:
Blocks: 1415598
TreeView+ depends on / blocked
 
Reported: 2016-12-23 10:54 UTC by Prasanth
Modified: 2018-12-06 19:56 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-20 18:26:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1112 normal SHIPPED_LIVE cns-deploy-tool bug fix and enhancement update 2017-04-20 22:25:47 UTC

Description Prasanth 2016-12-23 10:54:30 UTC
Description of problem:

Remove the kubectl CLI option from the deployment option and make OC as the default. The reason being, CNS deployments are mostly expected to be on OCP clusters and I don't see a requirement for supporting both CLI's in the same cns-deploy tool for downstream. If at all required in any use cases, it's better to have it separated out from this tool to avoid the complexity of the tool. 

Version-Release number of selected component (if applicable):
cns-deploy-3.1.0-5.el7rhgs.x86_64
openshift v3.4.0.36+ca20a16
kubernetes v1.4.0+776c994


How reproducible: 100%


Steps to Reproduce:
1. Install cns-deploy-3.1.0-5.el7rhgs.x86_64
2. Create a new namespace called "storage-project"
3. Setup a router as described in our official doc
4. Create a topology file
5. Execute # cns-deploy


Actual results: It gives the following prompt on a OCP setup:

#####
# cns-deploy 
Multiple CLI options detected. Please select a deployment option.
[O]penShift, [K]ubernetes? [O/o/K/k]:
#####

Expected results: Since CNS deployments are mostly on OCP clusters, I don't think there is a need for providing an extra CLI option for kubectl in the same tool. In that case, I would like the "kubectl" part to be removed from the cns-deploy tool or package it as 2 different scripts.


Additional info: Thoughts? / suggestions ?

Comment 4 Ramakrishna Reddy Yekulla 2017-02-17 11:06:39 UTC
https://github.com/gluster/gluster-kubernetes/pull/169

Comment 5 Ramakrishna Reddy Yekulla 2017-02-17 11:07:32 UTC
(In reply to Ramakrishna Reddy Yekulla from comment #4)
> https://github.com/gluster/gluster-kubernetes/pull/169

The Pull request to make the above changes is mentioned above.

Comment 6 Ramakrishna Reddy Yekulla 2017-02-20 06:44:36 UTC
Merged part of this commit ::  https://github.com/gluster/gluster-kubernetes/commit/faae51006c8a4fcbd43903af110f3ba10bb14a77

Comment 8 Prasanth 2017-03-30 11:46:37 UTC
Tested against the latest cns-deploy build and looks like now it takes OC as the default CLI option.

#########
# cns-deploy 
Welcome to the deployment tool for GlusterFS on Kubernetes and OpenShift.

Before getting started, this script has some requirements of the execution
environment and of the container platform that you should verify.

The client machine that will run this script must have:
 * Administrative access to an existing Kubernetes or OpenShift cluster
 * Access to a python interpreter 'python'
 * Access to the heketi client 'heketi-cli'

Each of the nodes that will host GlusterFS must also have appropriate firewall
rules for the required GlusterFS ports:
 * 2222  - sshd (if running GlusterFS in a pod)
 * 24007 - GlusterFS Daemon
 * 24008 - GlusterFS Management
 * 49152 to 49251 - Each brick for every volume on the host requires its own
   port. For every new brick, one new port will be used starting at 49152. We
   recommend a default range of 49152-49251 on each host, though you can adjust
   this to fit your needs.

In addition, for an OpenShift deployment you must:
 * Have 'cluster_admin' role on the administrative account doing the deployment
 * Add the 'default' and 'router' Service Accounts to the 'privileged' SCC
 * Have a router deployed that is configured to allow apps to access services
   running in the cluster

Do you wish to proceed with deployment?

[Y]es, [N]o? [Default: Y]: y
Using OpenShift CLI.
NAME              STATUS    AGE
storage-project   Active    2d
Using namespace "storage-project".
.........................


# cns-deploy -y
Using OpenShift CLI.
NAME              STATUS    AGE
storage-project   Active    2d
Using namespace "storage-project".


# cns-deploy -g -y
Using OpenShift CLI.
#########

Marking it as Verified.

Comment 10 errata-xmlrpc 2017-04-20 18:26:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1112

Comment 11 vinutha 2018-12-06 19:56:19 UTC
Marking qe-test-coverage as - since the preferred mode of deployment is using ansible


Note You need to log in before you can comment on or make changes to this bug.