Bug 140847 - X inside Xen only works when linux/libint10.a is moved
Summary: X inside Xen only works when linux/libint10.a is moved
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rik van Riel
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-25 14:55 UTC by Rik van Riel
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 05:14:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rik van Riel 2004-11-25 14:55:46 UTC
User-Agent:       
Build Identifier: 

it appears that Xen cannot (yet?) do vm86 emulation, so in order for X to start
up, /usr/X11R6/lib/modules/linux/libint10.a must be moved out of the way.  
Using the emulation in the other libint10.a, X starts up just fine.

I am wondering if it would be easier to make X fall back from one method to the
other, or to fix Xen to make vm86 mode work.  The end goal is to have X work
both on a native kernel and inside Xen, using the same config file.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1 Mike A. Harris 2004-11-25 14:58:37 UTC
Thanks Rik.  Will bounce this off the guys in our next meeting.


Comment 2 Rik van Riel 2004-11-28 15:01:57 UTC
The Xen developers just committed vm86 code to their tree.  I will try
 again with linux/libint10.a shortly, to see whether this X bugzilla
can be closed.

I'll keep you informed.

Comment 3 Mike A. Harris 2005-01-25 18:59:41 UTC
ping:  I'm not feeling too informed.  ;o)

Comment 4 Rik van Riel 2005-01-25 19:37:02 UTC
Heh.  I've been debugging some other issues, but will start looking at
vm86 mode again RSN.  Currently neither libint10.a works on my laptop,
presumably due to other issues ...

Xen really needs to be fixed up first, after that we can see whether X
needs changes too.

Comment 5 Mike A. Harris 2005-02-01 07:09:27 UTC
Ok, I'm going to reassign this to you for now then.  Please reassign
back to xgl-maint@redhat.com once Xen is fixed up if there are
problems in X that we need to investigate.

Thanks Rik.

Comment 6 Rik van Riel 2006-07-27 05:14:34 UTC
This bug seems to no longer exist, in either FC5 or rawhide.


Note You need to log in before you can comment on or make changes to this bug.