Bug 1408478 - cannot remove user belonging to group EvmGroup-super_administrator via tree
Summary: cannot remove user belonging to group EvmGroup-super_administrator via tree
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.8.0
Assignee: Roman Blanco
QA Contact: Satyajit Bulage
URL:
Whiteboard: appliance:configuration
: 1408479 (view as bug list)
Depends On:
Blocks: 1425494
TreeView+ depends on / blocked
 
Reported: 2016-12-23 16:31 UTC by Ievgen Zapolskyi
Modified: 2017-06-12 16:12 UTC (History)
7 users (show)

Fixed In Version: 5.8.0.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1425494 (view as bug list)
Environment:
Last Closed: 2017-06-12 16:12:44 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:
izapolsk: automate_bug+


Attachments (Terms of Use)
screen (deleted)
2016-12-23 16:31 UTC, Ievgen Zapolskyi
no flags Details

Description Ievgen Zapolskyi 2016-12-23 16:31:19 UTC
Description of problem:
When I create a user and add it to EvmGroup-super_administrator group, I can't remove it via tree. 
Configuration->Delete this User button is grayed out for all users belonging to EvmGroup-super_administrator group. Although, those users can be easily removed thru "Access Control EVM Users" page.

I suppose this bug is result of fix BZ 1090877.
Additionally, "Delete this User" menu item always shows a tooltip for "Administrator" user (see screenshot).


Version-Release number of selected component (if applicable):
5.7.0.17

How reproducible:
100%

Steps to Reproduce:
1. Go to Configuration->Access Control->Users page
2. Create a user and add it to EvmGroup-super_administrator group by clicking Configuration->Add a new User and filling appropriate fields
2. Find this just created user in the Access Control tree and select it
3. Try to click Configuration -> Delete this User 

Actual results:
Delete this User menu item is grayed out and shows tooltip for "Administrator" account.

Expected results:
It should be possible to remove such accounts except currently logged in account.

Additional info:

Comment 2 Dan Clarizio 2017-01-03 21:34:26 UTC
*** Bug 1408479 has been marked as a duplicate of this bug. ***

Comment 4 Harpreet Kataria 2017-01-09 22:10:09 UTC
Roman,

Looks like this was introduced with changes in https://github.com/ManageIQ/manageiq-ui-classic/commit/81fabce73104f18153b4304a0d159537514ccac6. Can you please take a look, let me know if you have questions.

Thanks,
~Harpreet

Comment 8 Satyajit Bulage 2017-05-03 10:34:27 UTC
Able to remove user account which belongs to EvmGroup-super_administrator group and role provided this user is not currently logged into the appliance.

Verified Version: 5.8.0.12-rc1.20170425180304_4f35996


Note You need to log in before you can comment on or make changes to this bug.