Bug 140848 - [PATCH] wrong mode timings in vga16fb.c require "nofb" installation
[PATCH] wrong mode timings in vga16fb.c require "nofb" installation
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Martuccelli
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-25 10:08 EST by Martin Wilck
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-23 14:08:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch that fixes the problem (954 bytes, patch)
2004-11-25 10:12 EST, Martin Wilck
no flags Details | Diff
patch for kernel 2.6 (1008 bytes, patch)
2004-11-25 10:12 EST, Martin Wilck
no flags Details | Diff

  None (edit)
Description Martin Wilck 2004-11-25 10:08:55 EST
Description of problem:

The mode timings of the default 640x480-60 mode in
drivers/video/vga16fb.c do not work with some LCD displays 
because they deviate slightly from the standard. In particular, the
screen height is wrong (529 vs. 525 pixels)

Version-Release number of selected component (if applicable):
2.4.21-20.EL and all others

How reproducible:
E.g. Installing RH on a system with an LCD screen that can't hanlde
slightly wrong VGA timings, without the "nofb" installation option.

Steps to Reproduce:
1.Install RH 

Actual results:
Screen will become black (or garbled, depending on display device)
after loader starts


Expected results:
Screen remains readable

Additional info:
I'll attach a patch. Problem was already discussed on the
linux-fbdev-devel mailing list.
Comment 1 Martin Wilck 2004-11-25 10:11:11 EST
Link to linux-fbdev-devel thread:

http://marc.theaimsgroup.com/?t=110128742300004&r=1&w=2
Comment 2 Martin Wilck 2004-11-25 10:12:10 EST
Created attachment 107461 [details]
patch that fixes the problem
Comment 3 Martin Wilck 2004-11-25 10:12:53 EST
Created attachment 107462 [details]
patch for kernel 2.6
Comment 5 Peter Martuccelli 2007-01-23 14:08:33 EST
Closing out as wontfix for RHEL3.

Note You need to log in before you can comment on or make changes to this bug.