Bug 1408503 - Please build oslosphinx with Ic4b47b19aa9db38557c37aed7722174b7dbdf4a1
Summary: Please build oslosphinx with Ic4b47b19aa9db38557c37aed7722174b7dbdf4a1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-oslo-sphinx
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Runge
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-23 21:23 UTC by Pete Zaitcev
Modified: 2017-01-12 05:23 UTC (History)
5 users (show)

Fixed In Version: python-oslo-sphinx-4.9.0-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-12 05:23:41 UTC
Type: Bug


Attachments (Terms of Use)

Description Pete Zaitcev 2016-12-23 21:23:31 UTC
Description of problem:

Build fails like this:

[zaitcev@lembas ~]$ rpmbuild -ba rpms/SPECS/python-swiftclient.spec 
.......................
Theme error:
unsupported theme option 'show_other_versions' given
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.4e8KQO (%install)

Because this:

[zaitcev@lembas ~]$ grep show_other /usr/lib/python3.5/site-packages/oslosphinx/theme/openstack/theme.conf
[zaitcev@lembas ~]$ 

The option is added by Ic4b47b19aa9db38557c37aed7722174b7dbdf4a1,
see https://review.openstack.org/340509
Not sure which release that is, we currently have 4.3.0, which
is obviously insufficient. Current latest is 4.9.0.

Version-Release number of selected component (if applicable):

python2-oslo-sphinx-4.3.0-3.fc26

How reproducible:

Synchronous

Steps to Reproduce:
1. rebuild python-swiftclient in Rawhide

Actual results:

Build fails

Expected results:

Build succeeds

Additional info:

I need this in F25 too, please.

Comment 1 Fedora Update System 2017-01-03 06:34:49 UTC
python-oslo-sphinx-4.9.0-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-beca5f153e

Comment 2 Fedora Update System 2017-01-03 22:21:07 UTC
python-oslo-sphinx-4.9.0-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-beca5f153e

Comment 3 Fedora Update System 2017-01-12 05:23:41 UTC
python-oslo-sphinx-4.9.0-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.