Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1408556 - [RFE] Add where host-to-guests mapping is pointing to in the rhsm.log
[RFE] Add where host-to-guests mapping is pointing to in the rhsm.log
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who (Show other bugs)
7.2
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Chris Snyder
Eko
Yehuda Zimmerman
: FutureFeature, Triaged
Depends On:
Blocks: 1420851 1469152
  Show dependency treegraph
 
Reported: 2016-12-24 16:47 EST by Kathryn Dixon
Modified: 2018-04-10 12:21 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
*virt-who* logs where the host-guest mapping is sent The *virt-who* utility now uses the `rhsm.log` file to log the owner or account to which the host-guest mapping is sent. This helps proper configuration of *virt-who*.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 12:19:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github virt-who/virt-who/pull/89 None None None 2017-08-02 16:55 EDT
Red Hat Product Errata RHEA-2018:0895 None None None 2018-04-10 12:21 EDT

  None (edit)
Description Kathryn Dixon 2016-12-24 16:47:17 EST
Description of problem:

When viewing the rhsm.log after setting up virt-who, it would be helpful to see where the host-to-guest mapping is reporting to. Even if it just took the output from the owner= in the virt-who config file. Which could be either /etc/virt-who.d/config or /etc/sysconfig/virt-who

This is what we see now..

2016-10-26 15:02:26,930 [INFO]  @subscriptionmanager.py:165 - Sending update in hosts-to-guests mapping: 

If that could show something like this..

2016-10-26 15:02:26,930 [INFO]  @subscriptionmanager.py:165 - Sending update in hosts-to-guests mapping to Default_Organization:

then we could see without the config file where the config is pointed to.

The /etc/virt-who.d/config - Does not come in a sosreport currently.

This would also help us if multiple vcenters are involved ( which is very common). 

Can help to verify quickly that the owner= is incorrect in the config without having to ask for it.

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. install and configure virt-who
2. view the rhsm.log for information/troubleshooting why hosts are not showing up in the portal/satellite6 depending on environment

Actual results: does not give us enough information to see where the hosts should be showing up ie portal or satellite

Sending update in hosts-to-guests mapping

Expected results: Sending update in hosts-to-guests mapping to Default_Organization <--- 


Additional info:
Comment 4 Kenny Tordeurs 2016-12-28 11:23:57 EST
@Kathryn

Just as FYI:

/etc/virt-who.d/config is included in recent sosreport for RHEL7 [0] and concerned errata [1]

[0] https://bugzilla.redhat.com/show_bug.cgi?id=1353552
[1] https://rhn.redhat.com/errata/RHBA-2016-2380.html
Comment 5 Kathryn Dixon 2016-12-28 11:33:21 EST
(In reply to Kenny Tordeurs from comment #4)
> @Kathryn
> 
> Just as FYI:
> 
> /etc/virt-who.d/config is included in recent sosreport for RHEL7 [0] and
> concerned errata [1]
> 
> [0] https://bugzilla.redhat.com/show_bug.cgi?id=1353552
> [1] https://rhn.redhat.com/errata/RHBA-2016-2380.html

Kenny thanks for the heads up =D
Comment 15 errata-xmlrpc 2018-04-10 12:19:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0895

Note You need to log in before you can comment on or make changes to this bug.